Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

There seems to be a problem with my network drivers. Neither eth0 nor wlan0 are recognized, and I'm running 13.04 over the 3.8.0-27-generic kernel.

Here's some diagnostic information:

  1. ifconfig yields an entry for lo and some virtual ethernet bridges, but no eth0 nor wlan0.

  2. nm-tool yields:

    NetworkManager Tool
    State: disconnected
  3. cat /etc/network/interfaces yields:

    auto lo
    iface lo inet loopback
  4. lshw -sanitize -C network yields:

    PCI (sysfs)
    *-network UNCLAIMED
        description: Network controller
        product: Centrino Wireless-N 1030 [Rainbow Peak]
        vendor: Intel Corporation
        physical id: 0
        bus info: pci@0000:02:00.0
        version: 34
        width: 64 bits
        clock: 33 MHz
        capabilities: pm msi pciexpress bus_master cap_list
        configuration: latency=0
        resources: memory:f7d00000-f7d01fff
    *-network UNCLAIMED
        description: Ethernet controller
        product: RTL8111/8168 PCI Express Gigabit Ethernet controller
        vendor: Realtek Semiconductor Co., Ltd.
        physical id: 0.2
        bus info: pci@0000:03:00.2
        version: 0a
        width: 64 bits
        clock: 33 MHz
        capabilities: pm msi pciexpress msix vpd bus_master cap_list
        configuration: latency=0
        resources: ioport:e000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff

What I've tried:

I tried to connect the NetworkManager Tool. From other sites, I've seen that it sometimes helps to change the file /etc/NetworkManager/NetworkManager.conf from:






And then doing a sudo service network-manager restart and/or rebooting the machine, but that has not worked either.

Any other ideas? Many thanks.

share|improve this question
It might help to add info about your network devices e.g. the output of sudo lshw -sanitize -C network – steeldriver Sep 28 '13 at 23:16
Updated, thanks. – Cody Sep 28 '13 at 23:54
What ethernet bridges? Is this running in a virtual machine? – chili555 Sep 29 '13 at 3:37
No, this is in the host. I have a couple of ethernet bridges that I use for some virtual machines (using lxc). – Cody Sep 29 '13 at 20:49
This is exactly the issue I am having -- did you manage to resolve it? Also: – tchakravarty Feb 8 '15 at 16:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.