Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I am trying to get started with juju on ec2. I have followed the install and configure instructions here: and here:

When I try to deploy I get

$ juju --verbose deploy mysql

2013-09-28 20:25:47 INFO juju.provider.ec2 ec2.go:187 opening environment "amazon" wordpress

2013-09-28 20:25:53 ERROR juju supercommand.go:282 command failed: no instances found error: no instances found

I have edited my .juju/environments.yaml so that the region, access-key, secret-key match my ec2 setup. I have left the admin-secret and control-bucket alone, and I have tried setting them to match the contents of the yaml file on my ec2 installation. I have also tried setting the default-series to 'precise'.

I can log in to ec2 and create instances and volumes.

I also have amazon-cert.pem and amazon-private-key.pem files in my .juju folder.

I have also tried installing wordpress, but get the same error. This is all happening from my OSX Mountain Lion machine, BTW.

Thanks, p

share|improve this question

closed as unclear what you're asking by Jorge Castro, Braiam, Eric Carvalho, Warren Hill, Seth Dec 13 '13 at 4:02

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

Can you confirm that you've done a juju bootstrap before trying the deploy commands? –  Jorge Castro Oct 3 '13 at 13:22