Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I've got a remote control and I want to make it so that when I press a button, my screensaver goes away but the problem is that when I set the keyboard shortcut and the screensaver is running, it shows the dialog where i need to enter my password... it's like it doesn't recognize any commands while the screensaver is running...

Also, I can't switch songs with my remote control while the screensaver is running but when i give it my password and unlock my computer then it understands my remote control...

Is there a workaround to this?

Thanks!

share|improve this question

1 Answer 1

The problem is that your remote only sends keycodes like any other keyboard. Thus, pressing keys on the remote will trigger the user authentication instead of what you want.

A simple workaround is to stop using the screensaver when the computer is idle. Instead, use power management to turn the screen of. It will solve your problem, and save the energy wasted on displaying the screensaver. When you want to explicitly require authentication, use the Lock Screen function.

To disable the screensaver, open System->Preferences->Screensaver and untoggle Activate screensaver when computer is idle. Note the time set under Regard the computer as idle after:

Screensaver Preferences

To turn off the screen instead, open System->Preferences->Power Management and enter the time you noted in Put display to sleep when inactive for: . Power Management

Now you should be able to continue using your remote when the screen is in power-save mode.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.