Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

From the related question here the first I did was purging Steam

The next step would then be to also remove related files in ~/.local/share/Steam and in addition to the answers from above ~/.steam.

One thing makes me believe there still will be more to do. The reason I purged Steam in the first place was that on other user's account we get a message to install Steam on every login:

enter image description here

This will definitely not come from files in my home directory, and can also not be from a system-wide Steam package, as this was purged as can be seen from the Synaptic window in the background of the shot above. Also in the other user's accounts there is no ~/.steam or ~/.local/share/Steam directory. Autostart applications in ~/.config/autostart/ or /etc/xdg/autostart have no Steam related entries.

Where do I have to look for this "installer" to also remove it? Will there be any other Steam-related files cluttering my drives?

Here is running 12.04 LTS amd64 on a productive desktop. Steam was installed initially from the Software Center.

share|improve this question

1 Answer 1

up vote 7 down vote accepted

I also had the same problem, but I can't seem to reproduce it now, so I haven't tested what I'm about to mention. But yeah, I think I've found the culprit.

After doing a simple locate steam to find all files that have the word steam in them, I found this file:

/var/lib/update-notifier/user.d/steam-install-notify

The contents of this file are:

Name: Steam Installer
Priority: Medium
Command: /usr/bin/steam
DontShowAfterReboot: False
ButtonText: Start Steam
DisplayIf: test ! -x ~/.steam/steam/ubuntu12_32/steam
OnlyAdminUsers: False
Description: 
 Start Steam to complete installation of the Steam for the current user.

I'm not familiar with the files in /var/lib/update-notifier, but this page: Ubuntu Wiki - InteractiveUpgradeHooks explains a bit.

So, what you can do to remove that window you're getting is to either:

  1. Rename or move the /var/lib/update-notifier/user.d/steam-install-notify file (or just delete it, but renaming/moving is a safer way, in case something goes wrong and you need the file back).
  2. Change DontShowAfterReboot: False to be DontShowAfterReboot: True. An educated guess would be that doing this change will not show the notification you're getting at every login.
  3. Use another DisplayIf test that will always be true.
share|improve this answer
1  
I suppose you could also create the file "~/.steam/steam/ubuntu12_32/steam" and mark it executable. The DisplayIf should fail then. This is perhaps an option if you have multiple users, and you actually want some of them to use Steam. –  edA-qa mort-ora-y Nov 23 '13 at 11:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.