Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'll just say that I am not experienced with Linux, and I've attempted to install Ubuntu on my Windows 8 UEFI laptop at least ten times this past month. I've tried the LTS 12.04 version which greeted me with no GUI but a simple terminal prompt asking me to log in. I assumed at first that 12 didn't exactly have as much support for UEFI than the latest 13.04 version, but after trying to boot that one, it returned an identical result!

I was able to install Ubuntu each time without error with a USB drive; I installed it on pre-made partitions (for the main OS and the swap) because it was suggested they're made before installing. But when I went to boot it -- I had to F12 and choose the correct boot, I planned to fix the common GRUB loader issue with Boot Repair -- it would give me the Ubuntu loading screen followed by a simple terminal. I've turned off fast startup, secure boot, and pretty much everything else required for a "smooth" install on UEFI. It's interesting to note that this issue also occurs when I use the "try Ubuntu before installing" option when booting from my USB drive. It would boot straight to a terminal.

Now, I've followed every possible solution given by other questions in this forum that I've found, the detailed instructions included in the UEFI tutorials, everything. I've even tried, out of desperation, following instructions that revolve around nivdia drivers, even though I have an AMD driver: maybe AMD UEFI computers are unsupported?

I tried things such as startx and that returns an error relating to xorg.conf, etc. I've tried uninstalling and reinstalling that with "solutions" but that too doesn't help. I'm certain this issue is due to my display?

I don't mind if there isn't a solution, I just need to know if there is or not. I'll be happy to give more information if that's required, I'm just unsure what to do at this point.

share|improve this question
1  
Can you post the error that startx returns? –  Goldentoa11 Sep 28 '13 at 2:17
2  
It's unclear whether you've installed Ubuntu in EFI mode or in BIOS mode. I recommend you run the Boot Info Script, which will create a file called RESULTS.txt that holds detailed technical information on your installation. Upload that file to a pastebin site (like the Ubuntu pastebin) and post the URL for your document here. That will enable better diagnostics. Posting the output of startx, as Goldentoa11 suggests, is also worthwhile. –  Rod Smith Sep 28 '13 at 16:49
    
Following the "instructions that revolve around nivdia drivers" are more likely to have negative than positive results in your case. Please provide the information that has been requested as that will help us help you! Thank you! –  Elder Geek Jun 17 at 14:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.