Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I cannot launch FireFox, as I'm getting the "Your Firefox profile cannot be loaded. It may be missing or inaccessible." error when I attempt to launch the latest FireFox in Ubuntu 13.04 (up to date). Bash produces the following:

(process:5052): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
Error: Access was denied while trying to open files in your profile directory.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.

I do not think this is a duplicate question, as I have tried the 3 solutions that are posted in one place or another. Here they are:

(1) Remove and reinstall FF. Attempting to launch produces the same error.

(2) Rename /home/[myname]/.mozilla from bash, then create a new folder to replace it, so as to make sure that the correct user owns the directory. Attempting to launch produces the same error, both in Unity and in terminal.

(3) chown the directory from bash, with

sudo chown myname /home/myname/.mozilla

or with

sudo chown myname:myname /home/myname/.mozilla

The command executes without problems, but launching FF produces exactly the same error as before. When I check the owner of the folder, it shows the correct user (me). Recursively setting ALL permissions to 777 (so there can't be a problem with the permissions still gives the same thing.

I can run 'sudo firefox' from bash. But bash throws a warning that the profile folder has the wrong owner (i.e., it's not owned by root).

So, any ideas?

UPDATE:

Complete purge removal via

sudo apt-get purge firefox firefox-globalmenu firefox-gnome-support

and reinstall with

sudo apt-get install firefox firefox-globalmenu firefox-gnome-support

Also does not work. Exactly the same behavior as before.

share|improve this question

4 Answers 4

up vote 2 down vote accepted

This seems to a known, system-dependent bug. Have a look at the link added at end (your precise error message). Following another link on that page, only suggestions I saw were to disable AppArmor if you run it; or roll FF back: Bug Report.

If nothing works, maybe give Chrome a try.

share|improve this answer
    
+1 'maybe give Chrome a try' –  Goldentoa11 Sep 28 '13 at 2:15
    
I'm primarily a Chrome user, but as a web developer I need to have FireFox working too, if only for testing. –  jeff_mcmahan Sep 28 '13 at 15:24
    
That sucks, as it really sounds it is bug based on the combination of your system with current FF. I would try to get a tarball of a slightly older version of FF then, and see if that version works. Not ideal, but better than nothing. Gl! –  gnometorule Sep 28 '13 at 16:55

Error: Access was denied while trying to open files in your profile directory.

Sounds like you're running into a permission error, where firefox is not allowed to read/write/execute the profile directory. Could you try running (using sudo)

chmod ug+rw ~/.mozilla -Rf

and see if that fixes the issue?

What that will do is grant read and write permission recursively to the user and group of the hidden ~/.mozilla folder. You also may need to grant execute permission on the folders as that will allow you to traverse into the folders.

== UPDATE ==

Just read through the part where you mentioned you essentially have done this already.

share|improve this answer

Found the below link that is related.

https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1180227

I did the following:

ls .cache/mozilla/
   ls: cannot open directory .cache/mozilla/: Permission denied

chown -R user.user .cache/mozilla/
    chown: cannot read directory ‘.cache/mozilla/’: Permission denied

sudo chown -R user.user .cache/mozilla/
firefox 

This fix my problem.

share|improve this answer
    
Thanks. This worked for me too. –  Jayadevan Jun 12 at 7:19

You have to remove/gain access on 2 folders:

~/.mozilla/firefox
~/.cache/mozilla

The .cache folder you can just delete :)

share|improve this answer

protected by Community Sep 8 at 15:48

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.