Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

how to change the numeric language to English from terminal & why the games are not working?

share|improve this question

Sounds like you want to change your locale settings.

  1. Type locale in the console and observer what comes up (Note if LC_ALL= is set to something, this over rides all other settings).
  2. If you want to change the numbers to english decimal (en_US.UTF-8), enter the following:

    su - (switch to root)

    export LC_NUMBERIC="en_US.UTF-8"

Try it out now and see.

Environment variables implement the locale codes. For example LANG=en_US.UTF-8 specifies that the computer uses US English with a UTF-8 encoding when displaying information.

Note: Type in locale -a to ensure you have the en_US.UTF-8 installed. If now use POSIX if you have that (I believe this is nessary but I am starting to doubt it now, most distro's will have that even if it isn't shown?)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.