Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having trouble accessing some files over a samba share. Here's my setup:

  • I have shared /shared as Shared
  • I have a user with the same name and pwd as my Linux user in my Windows machine
  • I made that user a member of the debian-transmission group
  • There's a symlink called /shared/Downloads/Torrents that points to /var/lib/transmission-daemon/downloads
  • That folder is owned by debian-transmission:debian-transmission and its permissions are 4775 (as created by the package)

I need to be able to read and move files from/to /shared/Downloads/Torrents from my Windows box.

Right now, I'm able to do that locally, but I get an access denied error when trying to read the Downloads folder.

share|improve this question
1  
A comparable question in Ask Different: How can you avoid error -43 when copying symlinked folder in Finder with a SAMBA share? –  Graham Perrin Oct 23 '12 at 23:38

2 Answers 2

up vote 3 down vote accepted

Have you enabled wide symlinks in the configuration for your share in smb.conf?

follow symlinks=yes
wide links = yes

Wide links at least is off by default as it might be exploited.

share|improve this answer
    
I have not, but it's the default according to samba.org/samba/docs/using_samba/ch08.html#samba2-CHP-8-TABLE-1. I have no problems accessing directories for which I'm the owner over symlinks (just tried) –  Diego Mijelshon Apr 14 '11 at 14:08
    
What you need is wide links as well. I have updated the answer. –  Egil Apr 14 '11 at 14:15
    
@Egil: it hasn't fixed the problem, but you are on to something, as I created a link to /home/myuser and I can't access it either. Still, isn't "yes" the default for wide links too? –  Diego Mijelshon Apr 14 '11 at 14:35
    
It was set to off by default following the post I linked to above (February 2010). –  Egil Apr 14 '11 at 14:43
5  
You may also need "unix extensions = no" in your [Global] –  charlesbridge Apr 14 '11 at 18:39

From a comment on the previous answer from user charlesbridge (and from the smb.conf docs/manpages), accessing links outside of the share root requires enabling the wide links parameter, which requires both follow symlinks = yes and unix extensions = no. You must ensure your smb.conf has the following settings (explicitly or implicitly):

follow symlinks = yes
wide links = yes
unix extensions = no
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.