Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was helping my friend installing gem5 simulator on Linux for her thesis work. I know Linux a little bit. Somehow I managed to install that simulator on my laptop with Ubuntu 12.04, but when I tried to install that simulator on her laptop it didn't go well. I gave the same commands on her laptop but it gave this error.

$ scons build/ALPHA/gem5.opt
scons: Reading SConscript files ...
Error Don't know what compiler options to use for your compiler.
compiler: None
version: COMMAND NOT FOUND!
If you're trying to use a compiler other than GCC
or clang, there appears to be something wrong with your
environment.

If you are trying to use a compiler other than those listed
above you will need to ease fix SConstruct and 
src/SConscript to support that compiler.

I tried same commands to install gem5 simulator by re installing ubuntu on her laptop. But same error. Then I tried on Linux Mint 15 and Fedora but got the same error. What am I doing wrong? Can somebody provide step by step guide to perform installation of gem5 simulator or can anybody can provide me a .deb file of it?

If not please at-least guide me how to create deb file of that sim, but please consider my skills are of beginner's level.

share|improve this question
    
I believe you have to install gcc-arm-linux-gnueabi and libc6-dev-armel-cross before. –  Braiam Sep 26 '13 at 18:58

2 Answers 2

Well I checked out the dev tree and ran scons and it just worked™. I would guess from the error you're seeing that means you don't have a compiler (scons is only a replacement for make, not gcc). This is where reading the README file or the dependencies page comes in handy.

sudo apt-get install build-essential scons swig zlib1g-dev m4 protobuf{-c,}-compiler

I compile other stuff, so apart from scons I was already good to go.

share|improve this answer
up vote 0 down vote accepted

This worked for me !! Thanks !!!

 sudo apt-get install swig gcc m4 python python-dev libgoogle-perftools-dev mercurial scons g++ build-essential
 hg clone http://repo.gem5.org/gem5
 cd gem5/
 scons build/ARM/gem5.opt -j2
 build/ARM/gem5.opt configs/example/se.py -c tests/test-progs/hello/bin/arm/linux/hel­lo
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.