Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I'm using Ubuntu 13.04 , it can't read Arabic letters and words properly. that what I get when I open files contains Arabic, please notice that same files are showed correctly on windows:

ÇáÞÇäæä íÌÈÑ ÇáíåæÏ Úáì ÇáÚíÔ
ÈãäØÞÉ ãÚÒæáÉ ãä ÇáãÏíäÉ ÊÏÚì ÇáÌíÊæ
share|improve this question

marked as duplicate by Sneetsher, Paranoid Panda, Eric Carvalho, Ravan, Charles Green Nov 20 '15 at 2:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
...and what are the files you open? – mikewhatever Sep 26 '13 at 8:37
1  
Seems the matter of encoding. – AliNa Sep 26 '13 at 9:03

Are you using Ubuntu in Arabic? If not then I would suggest downloading the language packs straight from System Settings--->Language Support--->Install/Remove Language

Active Internet connection required BTW

share|improve this answer
2  
What makes you think you need to have all of Ubuntu in Arabic only to read an Arabic text? Suppose, the OP is a student of Arabic, and only wants to open an exercise? Changing the interface language just for that is a major overkill, don't you think? – mikewhatever Sep 27 '13 at 16:29

Try this:

sudo apt-get install libfribidi0 libfribidi-dev

Also, install THIS package.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.