Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
Please check your credentials or use 'juju bootstrap' to create a new environment.  Error details: no reachable servers.
Error: Unable to connect to environment "maas". Please check your credentials or use 'juju bootstrap' to create a new environment.
Error details: no reachable servers

I have 2 nodes are ready on maas server and when I run juju bootstrap one of them going to located to root user but I still got the error massage I mentioned above this my environment file,

environments:
  maas: 
    type: maas
    maas-server: 'maas-server-ip-address/MAAS'; 
    maas-oauth: 'vzgAAtkW9YftwMRDxb:z9EHbEgsBjMNjbP5r4:9AdTb7gMU39FvPBKHsbPYNT9FAtFGscs' 
    admin-secret: 'my-root-password'
    default-series: 'precise'

Edit:

The out put of juju bootstrap -v --debug it's too much but the end of output is:

WARNING juju.provider.maas environ.go:181 picked arbitrary tools &{"1.14.1-precise-amd64" "172.26.0.10:80/MAAS/api/1.0/files/…;} 
2013-09-26 13:06:41 DEBUG juju.provider.maas environ.go:267 maas user data; 9888 bytes 
2013-09-26 13:06:41 DEBUG juju.provider.maas environ.go:273 started instance "/MAAS/api/1.0/nodes/node-bb337654-25dc-11e3-ac82-70f39519a2c5/" 
2013-09-26 13:06:41 INFO juju supercommand.go:284 command finished 

my environment file again is

environments:
  maas:
    type: maas
    maas-server: '172.26.0.10:80/MAAS/';
    maas-oauth: 'p3PeSub2ajPWVKL7pH:bZAWke8fydgAsBL8NQ:ZkZMjx5XvptMzrPgy2LqvA5W6BAWPCdj'
    admin-secret: 'admin-password'
    default-series: precise
    authorized-keys-path: ~/.ssh/id_rsa.pub

My server's hostname is hu , and I think my problem is the admin password because I have read it has to be replaced with a random pass-phrase. Thanks for your help.

share|improve this question
    
Can you please run juju destroy-environment, then run juju bootstrap -v --debug and post the output of that command? Also, make sure your maas server is a FQDN, http://mass-server-ip-address:80/MAAS for example. –  Marco Ceppi Sep 26 '13 at 10:00
    
my environment file again is environments: maas: type: maas maas-server: '172.26.0.10:80/MAAS/'; maas-oauth: 'p3PeSub2ajPWVKL7pH:bZAWke8fydgAsBL8NQ:ZkZMjx5XvptMzrPgy2LqvA5W6BAWPCdj' admin-secret: 'admin-password' default-series: precise authorized-keys-path: ~/.ssh/id_rsa.pub –  aboumawada Sep 26 '13 at 12:57
    
the out put of juju bootstrap -v --debug it's too much but the end of output is ,,,, WARNING juju.provider.maas environ.go:181 picked arbitrary tools &{"1.14.1-precise-amd64" "172.26.0.10:80/MAAS/api/1.0/files/…;} 2013-09-26 13:06:41 DEBUG juju.provider.maas environ.go:267 maas user data; 9888 bytes 2013-09-26 13:06:41 DEBUG juju.provider.maas environ.go:273 started instance "/MAAS/api/1.0/nodes/node-bb337654-25dc-11e3-ac82-70f39519a2c5/" 2013-09-26 13:06:41 INFO juju supercommand.go:284 command finished –  aboumawada Sep 26 '13 at 13:38
    
my server hostname is hu , and i think my problem in the admin password because i read it have to be replaced with a random pass-phrase , Thanks for your help –  aboumawada Sep 26 '13 at 13:44
    
Can you please add this information into your question and not these comments? Thanks! –  Jorge Castro Oct 3 '13 at 13:23

2 Answers 2

You should remove the semicolons at he ends of the lines.

Also, for the admin-secret, this is just going to be the password for various machines set up with Juju. Just set it to anything hard to guess.

On the maas-server line, you need to have a http:// before it, making the while line something like

    maas-server: 'http://172.26.0.10/MAAS/'

The picked arbitrary tools message is fine, mine does that and has no ill effects.

Make sure you take the maas-oauth value from the MaaS web UI on the user preferences page (it calls it a key).

So, the whole environments.yaml file should look about like this:

environments:
  maas:
    type: maas
    maas-server: 'http://172.26.0.10/MAAS/'
    maas-oauth: 'p3PeSub2ajPWVKL7pH:bZAWke8fydgAsBL8NQ:ZkZMjx5XvptMzrPgy2LqvA5W6BAWPCdj'
    admin-secret: '5fjC6PPeO9XwrPu1TfNmMWD4q'
    default-series: precise
    authorized-keys-path: ~/.ssh/id_rsa.pub
share|improve this answer

I got a very similar error when I tried to bootstrap Juju when I had two nodes that were both in the "Allocated" state. I had to "Stop" one of the two nodes, putting it into the "Ready" state and bootstrap again. Not sure if that's your issue but it's something I ran into.

Hope that helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.