Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I have set up samba successfully and I am using it for file shares but when trying to do media shares I am having issues. Specifically the problem is that I can see the Media folder in Windows but then I can't go into them. I get permission denied. I have changed the /media/username to soft link to a /media/share folder and this is working. The problem is that the file system won't let me change permissions on a media sub directory even as root. As a result, I am trying to see if anyone else is sharing their media from a linux machine to a windows machine. See below my attempt to change the directory perms. My Passport is a WD external hard drive. I can see the My Passport folder in Windows I just can't open it.

soft link:

root@BigJackFly:/media# ls -ltr
total 4
lrwxrwxrwx 1 root   root       5 Sep 25 18:41 bjackfly -> share
drwxr-xr-x 4 nobody nogroup 4096 Sep 25 20:48 share


root@BigJackFly:/media/share# chmod 777 My\ Passport/
root@BigJackFly:/media/share# ls -ltr

drwx------ 1 bjackfly bjackfly 4096 Sep 25 21:04 My Passport

smb.conf
[mediashare]
   comment = Public Stuff
   path = /media/share
   browseable = yes
   guest ok = yes
   read only = no
   create mask = 0775
share|improve this question
    
Does anyone have any advice? I am sure I am not the first to do this. Is there a better place I should post this question where someone might know?? –  bjackfly Oct 5 '13 at 16:33
    
What filesystem is the external harddrive formatted with? Some filesystem do not support unix permissions –  dan08 Oct 16 '13 at 15:42
add comment

1 Answer 1

I got the same problem and solved it by adding the user to the samba share, with this command:

sudo smbpasswd -a <USERNAME>

just change < USERNAME > by the username (an ubuntu prevously added user) you want to access to the shared resource.

Also I didn't change any file, I just right click the folder from nautilus and use "Sharing options" menu.

Hope this help you

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.