Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using dell-inspiration 14r,Last day, when I shutdown ubuntu, Next time It didn't boot, It said hard-drive not found, try reseating it. But It ,Again,could detect the hard-drive from boot menu.I tried many things, Nothing seemed to work. At last, I downloaded a booted lubuntu 13.04 and installed it. Now the grub bootloader menu comes up asking me which to boot. I changed boot option's from legacy to UEFI. Now In both the booting System, Ubuntu says that boot/efi is not ready, press S to continue.How to fix this error? Also How Installing lubuntu get's me to the login screen again?

Edit: I also found that when I try to boot in EFI mood, It tells start pxe over IPv4 Now, When I enter to the boot menu I see at #1 Ubunt(hard drive not present) that is bios is not detecting My OS. So the problem here is, Ubuntu isn't been able to boot itself.That's why installing lubuntu I was able to boot. Now what should I do to fix this error?

share|improve this question

closed as off-topic by Braiam, Eric Carvalho, Danatela, Ask, Avinash Raj Apr 15 at 13:01

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

up vote 1 down vote accepted

You've probably got filesystem damage on your EFI System Partition (ESP), which is mounted at /boot/efi in Ubuntu. This type of damage is often caused by the Windows Fast Startup feature, which can do serious damage to filesystems on a dual-boot configuration. It's imperative that you disable this feature when dual-booting with Windows. See this page for instructions on disabling this feature.

After you disable Fast Startup, you may also need to repair filesystem damage on the ESP. You can do this in Linux with the dosfsck command, as in sudo dosfsck /dev/sda1; however, you'll need to know what partition to pass as an argument, as that varies from one computer to another. Type sudo parted /dev/sda print to see your partition table. The ESP can be identified as a FAT partition with its "boot flag" set. Alternatively, you can use CHKDSK or its GUI equivalent in Windows, but I'm less sure of the exact procedure there, so I can't provide details. In a worst-case scenario, you might need to copy all the files off of the ESP, create a fresh FAT32 filesystem on it, and copy all the files back. If you do this, you'll probably have to adjust your /etc/fstab file in Linux to get the partition to mount correctly, since its serial number ("UUID," although it's not technically a UUID) will probably have changed.

share|improve this answer
    
I don't have a windows OS, I just have Ubuntu.I think the problem might be in bootloader. The thing is , I accidentally tried to format my entire hard drive with disk utility while I was trying to format a usb-flash.. may be that was the problem –  user196199 Sep 26 '13 at 17:22

The problem is the BIOS. You will need to enter your bios. Disable UFEI boot and enable legacy support. In other words you need to disable secure boot. I had this same error on a brand new HP Pavilion out of the box; where I wiped windows 8 for a clean ubuntu 13.04 server. Let me know if you have any questions.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.