Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Previously I had Ubuntu 12.4 running as second OS on a second boot partition, installed with bootcamp (no rEFIt). Now I tried to install Ubuntu 13.4 (amd64) from USB but it failed to install Grub ('bootloader installation failed') on /dev/sda3 (the fresh Ubuntu partition). Since there is no further error message, I'm kind of puzzled about this. When I startup the MacBook and choose "windows" (this name is due to bootcamp and was that way with 12.4 all the time) from the EFI boot menu, grub "loads" but says: error, file not found

I googled around and tried a few things:

Running the live-ubuntu and manually installing grub via:

sudo mount /dev/sda3 /mnt
sudo grub-install /dev/sda3 --[b/r]oot-directory="/mnt" --force

... didn't work. Apparently it installed Grub but spit out a lot of warnings the usage of blocklists and I still couldn't boot.

Installing rEFIt and trying the whole installation over and over again ... didn't work.

So ... any ideas why grub-install fails? Does the 64bit-version only supports (u)efi-boot and there are issues due to the old hardware/firmware?

The setting: Macbook 5,1(late 2008) with OSX 10.8 Ubuntu 13.4 64bit on USB The disk is healthy (says disk-warrior and diskutil on osx) and the partition tables are synchronized (rEFIt)

Update: I tried the 32bit-version: After uninstalling rEFIt, I wasnt able to boot from usb-ununtu anymore. So I installed rEFInd, run the installation (I think the usb was booted with efi and not with bios because I didn't see grub before the installation!) and et voilá, the bootloader installed. BUT: I'm still not able to boot into the newly installed ubuntu. Same as above: error, file not found. >grub rescue: ... Did I kill my bootloader??!

Update2: After completely removing the ubuntu partition and reassigning its space to the osx partition, rEFInd still thinks there is a linux partition somewhere ... the usb-ubuntu still doesn't show up under the macbooks bootloader (but still under rEFInd)

Update3: Reinstalling 13.4 32bit now results in a blinking underscore right after rEFInd, for booting the installation as well as the live-version from usb. wtf?

share|improve this question
    
I ended up formatting the whole disk and reinstalling osx + ubuntu. Apparently efi and the bios emulation bootloader were somehoew broken beyond repair. –  stfn Sep 30 '13 at 14:16
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.