Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I need to use v4l1compat.so with Skype. This used to work, but now running this:

LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype

produces this:

ERROR: ld.so: object '/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so' from LD_PRELOAD cannot be preloaded: ignored.

(The object files are definitely present).

Current workaround:

Make an Ubuntu 12.04 liveCD/USB. Copy all of the libraries and the Skype binary into a folder on the desired system. Then, run

LD_PRELOAD=$(pwd)/lib/v4l1compat.so LD_LIBRARY_PATH=$(pwd)/lib  ./skype

where lib is the subfolder into which the libraries have been copied.

List of required libraries:

http://pastebin.com/iyV33Db7

This works perfectly, but obviously this isn't ideal.


Any better or more permanent solutions?

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.