Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
  • I am running Ubuntu 13.04 and Windows XP.

  • I am a samba newbie but was able to set this up on Ubuntu following the instructions posted here https://help.ubuntu.com/13.04/serverguide/samba-fileserver.html

  • My question is that although I can copy a word document to the share from linux, when I edit it in Word on Windows I cannot save and overwrite the file. It says the file is read only.

  • I have to save a copy and then do a move of the file on the Linux system.

  • I tried changing the perms of the file to 777 on the linux side but this didn't fix it so I am thinking it is a perms at the user level.

  • Does anyone know off the top of their head? I currently have security = user in my smb.conf file.

  • When copying a file from linux to the share it has my user name on it. When creating a file from windows to the share it has nobody nogroup on the file.

  • The good news is both linux and windows see the same files and I can open all the files put on the share in windows I just can't overwrite them with edits ( word 2007 files specifically ).

  • Any help on the setting to fix this is appreciated.

samba details

[share]
   comment = Unbuntu File Share
   path = /srv/samba/share
   browseable = yes
   guest ok = yes
   read only = no
   create mask = 0775

permissions of all the directories for /srv/samba/share

bjackfly@BigJackFly:~$ ls -ltr | grep srv
drwxr-xr-x   3 root root  4096 Sep 25 14:05 srv

bjackfly@BigJackFly:~$ ls -ltr /srv/ | grep samba
drwxr-xr-x 3 root root 4096 Sep 25 14:05 samba

bjackfly@BigJackFly:~$ ls -ltr /srv/samba/ | grep share
drwxrwxrwx 2 nobody nogroup 4096 Sep 25 17:25 share
share|improve this question
    
Could you post at least the [YourShareName] portion of your smb.conf file and also the output of ls -la /srv/samba/YourShareName? There's a good chance that your create mask = 0755 line is wrong or missing or that your skipped the chown step. –  Phoeey Sep 25 '13 at 21:55
    
I added the details requested. Thanks for looking into this. –  bjackfly Sep 25 '13 at 22:49
add comment

1 Answer 1

up vote 0 down vote accepted

I had to make sure that files in the share had nobody.nogroup

sudo chown nobody.nogroup  file.docx
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.