Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to Linux and I am trying to learn as much as possible. I have installed Unbutu 13.0.4 and selected basic server, I am now trying to setup VPN to access my files from anywhere. However getting errors when disabling encryption. The steps I am following is below from one of the member here:

I am getting errors on doing the steps below:

refuse-pap
refuse-chap
refuse-mschap

Error message: access denied, even though I am logged on as root.

Any help will be much appreciated!

share|improve this question
1  
Which instructions? Can you add a link to them and can you let us know at what point it goes wrong together with what error message you get –  Warren Hill Sep 25 '13 at 12:24
1  
@Braiam Comment those lines, not add –  Radu Rădeanu Sep 26 '13 at 18:27
1  
And Radu beat me to explaining this in an answer. :P But yes, as Radu says, there are no commands to run. You need to edit /etc/ppp/pptpd-options as root (sudo nano /etc/ppp/pptpd-options or replace nano with your favorite command line text editor) and comment out all three of those lines with a # character at the beginning. I have edited my answer on the guide/link you're using to expand on how to edit a file on the command line... (sorta). –  Thomas W. Sep 26 '13 at 18:34

1 Answer 1

These are no commands to execute them in terminal. At the step 3 it says clear:

3: Edit /etc/ppp/pptpd-options. Comment out these lines, if you want this to work universally on all OSes:

refuse-pap
refuse-chap
refuse-mschap

You can comment this line if you want to disable encryption: require-mppe-128

So, open /etc/ppp/pptpd-options file with root privileges, using the following command:

sudo -i gedit /etc/ppp/pptpd-options

and comment those lines by adding a hash (#) character in front of each one. When you finish, save the file and clse it.

share|improve this answer
1  
Or, use nano, if you're working with a remote server and don't have a GUI. I put instructions to use nano, because I always am working on this stuff remotely and can't X-forward. –  Thomas W. Sep 26 '13 at 18:41
    
Thanks for making it all very clear to me i will go ahead and and edit –  user195992 Sep 27 '13 at 20:15
    
Thanks Radu i manged to do that all good now. How ever i am now step 10 were i have to edit the ufw 10: This step assumes you have UFW. Edit /etc/ufw/before.rules, and add the following either at the beginning of /etc/ufw/before.rules or just before the *filter rules (recommended). when the nano editor opened the page was blank i was suprised to see blank screen i still proceeded to enter the details. i am i in the right track here? –  user195992 Oct 3 '13 at 21:09
    
@user195992 Where you wish - I will choose recommended... If this answered your question, you may mark this answer as accepted, by clicking the green check mark next to it. That will indicate that your problem is solved. –  Radu Rădeanu Oct 3 '13 at 21:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.