Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a wireless router that assigns IPs using DHCP. My laptop (Acer Aspire 1 110L running Ubuntu 10.10) connects to the wireless network, but DNS is not working. I've tried to trouble shoot the problem following various tutorials on ubuntu help, but I'm stuck.

(My laptop works fine with other wireless networks, and other computers can connect to the Internet using the router in question. My laptop worked fine with this router until a few weeks ago. Unfortunately I don't know what changed to cause the problem. I tried booting into various older kernels that are still on the system, but that didn't fix the problem.)

I can connect to the wireless network. The network manager applet indicates the connection is successful.

ifconfig indicates that my computer is assigned an IP address (192.168.0.105).

/etc/resolv.conf contains one line:

nameserver 192.168.0.1

netstat -nr indicates that I have a default route to 192.168.0.1

I can ping 192.168.0.1, and my laptop (i.e., localhost, 127.0.0.1, 192.168.0.105). I can't ping other names (e.g., www.askubuntu.com) or addresses (e.g., 64.34.119.12).

What should I do next to try to fix this problem?

Thanks!

share|improve this question
    
is nslookup working? –  geoh May 13 '12 at 17:40
add comment

1 Answer

/etc/resolv.conf contains your DNS listings. 192.168.0.1 is obviously the router in question. You need to manually provide the nameserver(s) provided to you by your isp. You can usually get this information under the router/status page. In your case the router is not a nameserver and therefore will not resolve DNS.

Network-Manager will overwrite the /etc/resolv.conf to accomadate dhcp configured connections. Playing around with mixed static and dhcp connections can sometimes trigger this file to be overwritten. You could also try letting network-manager have another shot by manually restarting networking.

$ sudo /etc/init.d/networking restart 

We can also try to resolve the problem directly utilizing dhclient.

$ sudo dhclient -r
$ sudo dhclient 
share|improve this answer
    
I love you. Let me double your points. –  WernerCD Jun 26 '12 at 16:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.