Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
How do I fix this “E:Type '*' is not known on line * in source list …” update error?

I went to update to 11.04 and my Update Manager is missing completely from the System file. Is there any way to upgrade without re-installing the whole program? (I have a back-up on an external hard drive if push comes to shove.) Yes I tried sudo apt-get -- it almost worked. The pages fly by and I get a pop-up window that starts " END-USER LICENSE AGREEMENT FOR MICROSOFT SOFTWARE " I scroll down and come to a "" at the bottom of the page.

It does not work. The page just sits there when I click on it. Alt O just blinks the screen. Enter does nothing. I went up to the menu bar and found reset under the terminal button. When I click on that I get a log page of an install/update the last part of the log says:

"dpkg: warning: files list file for package `ttf-mscorefonts-installer' missing, assuming package has no files currently installed. (Reading database ... 169536 files and directories currently installed.) Preparing to replace ttf-mscorefonts-installer 3.2ubuntu2 (using .../ttf-mscorefonts-installer_3.2ubuntu2_all.deb) ...

I now have an update manager file under system->Admin->update manager but when I run it I get this error message

"Could not initialize the package information. An unresolvable problem occurred while initializing the package information. Please report this bug against the 'update-manager' package and include the following error message:

'E:Type 'b-src' is not known on line 2 in source list /etc/apt/sources.list.d/ubuntu-wine-ppa-maverick.list'

share|improve this question

marked as duplicate by htorque, Stefano Palazzo Jan 19 '12 at 23:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

What version are you upgrading from? – belacqua Apr 14 '11 at 3:54

Did you try sudo apt-get install update-manager ?

share|improve this answer
I have 10-10 in my machine. – jredburn Apr 14 '11 at 13:16
sudo rm /etc/apt/sources.list.d/ubuntu-wine-ppa-maverick.list
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.