Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am very new to ubuntu/linux. I have recently switched my laptop to Ubuntu 13.04 after I had an issue with Vista.

I have downloaded one of my favorite old games, Panzer General. I downloaded the zip file extracted it gotten the .exe file and am able to get it to run by right-clicking and using Open With...WINE windows program loader. However, if I go into properties(to make it the default), WINE does not appear in the list of applications to 'Open With' and the add button is un-clickable.

Any help would be great, thanks!

share|improve this question

marked as duplicate by Warren Hill, Radu Rădeanu, Eric Carvalho, Mitch, Kevin Bowen Sep 25 '13 at 13:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
See my answer on the question I linked, it works perfectly ;) –  Gerhard Burger Sep 25 '13 at 5:28
    
use this command to make Windows App/Installer open automatically upon clicking, open terminal, then, type gedit ~/.local/share/applications/mimeapps.list , add this line application/x-ms-dos-executable=wine.desktop; and you're ready to go! –  Shaharil Ahmad Sep 25 '13 at 5:36
    
@ShaharilAhmad I added and saved this to list, and it did the trick! I am able to double click and it fires right up. –  user195860 Sep 25 '13 at 12:32
add comment

2 Answers 2

If you have Ubuntu Tweak use this to set your preferences. If not download it via "software Centre" It will do what you want. Regards - Mal

share|improve this answer
    
I was not able to locate Ubuntu Tweak in the software center or the computer. I don't know if there is a newer version or it goes by another name now. –  user195860 Sep 25 '13 at 12:26
add comment

I might have the answer for your question, but I am not sure. I am confortable with the 12.04 version. However, this could help.

When you right-click on the .exe file, you go to "Open with application with", then you select WINE. Sometimes, like your case, it appears to be that the application is not available. So, you choose the option where you find the wine executable for Linux (which must be located at \usr\bin\wine.

If this doesn't work, got into the system settings, then got into the general settings tab, then on the applications tab, I think you can choose your app at the same way.

If these don't work, tell me and I will try it myself with screenshots (but from Debian: don't be afraid, Ubuntu is a Debian based operating system). Regards,

The Drummer from Kubuntu.

share|improve this answer
    
Right-clicking the file would allow me to get it open with WINE. The Archive Manager was still the default and WINE was not selectable in the other applications in the properties-->open with tab. –  user195860 Sep 25 '13 at 12:36
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.