Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

when I try to install ia32-libs I got this error:

asdfg@notebook:~$ sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 adduser : Depends: passwd (>= 1:4.0.12)
           Recommends: ecryptfs-utils (>= 67-1) but it is not going to be installed
 ia32-libs : Depends: ia32-libs-multiarch
 openssh-client : Depends: passwd
 procps : Depends: initscripts
 upstart : Depends: initscripts
           Depends: mountall
           Depends: ifupdown (>= 0.6.10ubuntu5)
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

When I try to install ia32-libs-multiarch :

Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs-multiarch:i386 : Depends: bluez-alsa:i386 but it is not going to be installed
                            Depends: libgettextpo0:i386 but it is not going to be installed
                            Depends: gstreamer0.10-plugins-base:i386 but it is not going to be installed
                            Depends: gstreamer0.10-plugins-good:i386 but it is not going to be installed
                            Depends: gtk2-engines:i386 but it is not going to be installed
                            Depends: gtk2-engines-murrine:i386 but it is not going to be installed
                            Depends: gtk2-engines-pixbuf:i386 but it is not going to be installed
                            Depends: gtk2-engines-oxygen:i386 but it is not going to be installed
                            Depends: gvfs:i386 but it is not going to be installed
                            Depends: ibus-gtk:i386 but it is not going to be installed
                            Depends: libacl1:i386 but it is not going to be installed
                            Depends: libao4:i386 but it is not going to be installed
                            Depends: libasound2:i386 but it is not going to be installed
                            Depends: libasound2-plugins:i386 but it is not going to be installed
                            Depends: libasyncns0:i386 but it is not going to be installed
                            Depends: libattr1:i386 but it is not going to be installed
                            Depends: libaudio2:i386 but it is not going to be installed
                            Depends: libcanberra-gtk-module:i386 but it is not going to be installed
                            Depends: libcap2:i386 but it is not going to be installed
                            Depends: libcapi20-3:i386 but it is not going to be installed
                            Depends: libcups2:i386 but it is not going to be installed
                            Depends: libcupsimage2:i386 but it is not going to be installed
                            Depends: libcurl3:i386 but it is not going to be installed
                            Depends: libdbus-glib-1-2:i386 but it is not going to be installed
                            Depends: libesd0:i386 but it is not going to be installed
                            Depends: libfontconfig1:i386 but it is not going to be installed
                            Depends: libfreetype6:i386 but it is not going to be installed
                            Depends: libgail-common:i386 but it is not going to be installed
                            Depends: libgconf-2-4:i386 but it is not going to be installed
                            Depends: libgdbm3:i386 but it is not going to be installed
                            Depends: libglapi-mesa:i386
                            Depends: libglu1-mesa:i386 but it is not going to be installed
                            Depends: libgphoto2-2:i386 but it is not going to be installed
                            Depends: libgphoto2-port0:i386 but it is not going to be installed
                            Depends: libgtk2.0-0:i386 but it is not going to be installed
                            Depends: libmpg123-0:i386 but it is not going to be installed
                            Depends: libncursesw5:i386 but it is not going to be installed
                            Depends: libnspr4:i386 but it is not going to be installed
                            Depends: libnss3:i386 but it is not going to be installed
                            Depends: libodbc1:i386 but it is not going to be installed
                            Depends: libopenal1:i386 but it is not going to be installed
                            Depends: libpulse-mainloop-glib0:i386 but it is not going to be installed
                            Depends: libqt4-dbus:i386 but it is not going to be installed
                            Depends: libqt4-network:i386 but it is not going to be installed
                            Depends: libqt4-opengl:i386 but it is not going to be installed
                            Depends: libqt4-qt3support:i386 but it is not going to be installed
                            Depends: libqt4-script:i386 but it is not going to be installed
                            Depends: libqt4-scripttools:i386 but it is not going to be installed
                            Depends: libqt4-sql:i386 but it is not going to be installed
                            Depends: libqt4-svg:i386 but it is not going to be installed
                            Depends: libqt4-test:i386 but it is not going to be installed
                            Depends: libqt4-xml:i386 but it is not going to be installed
                            Depends: libqt4-xmlpatterns:i386 but it is not going to be installed
                            Depends: libqtcore4:i386 but it is not going to be installed
                            Depends: libqtgui4:i386 but it is not going to be installed
                            Depends: libqtwebkit4:i386 but it is not going to be installed
                            Depends: librsvg2-common:i386 but it is not going to be installed
                            Depends: libsane:i386 but it is not going to be installed
                            Depends: libsdl-mixer1.2:i386 but it is not going to be installed
                            Depends: libsdl-image1.2:i386 but it is not going to be installed
                            Depends: libsdl-net1.2:i386 but it is not going to be installed
                            Depends: libsdl-ttf2.0-0:i386 but it is not going to be installed
                            Depends: libsdl1.2debian:i386 but it is not going to be installed
                            Depends: libsqlite3-0:i386 but it is not going to be installed
                            Depends: libssl0.9.8:i386 but it is not going to be installed
                            Depends: libssl1.0.0:i386 but it is not going to be installed
                            Depends: libstdc++5:i386 but it is not going to be installed
                            Depends: libstdc++6:i386 but it is not going to be installed
                            Depends: libxaw7:i386 but it is not going to be installed
                            Depends: libxml2:i386 but it is not going to be installed
                            Depends: libxp6:i386 but it is not going to be installed
                            Depends: libxslt1.1:i386 but it is not going to be installed
                            Depends: libxss1:i386 but it is not going to be installed
                            Depends: libxtst6:i386 but it is not going to be installed
                            Depends: odbcinst1debian2:i386 but it is not going to be installed
                            Depends: libpulsedsp:i386 but it is not going to be installed
                            Depends: xaw3dg:i386 but it is not going to be installed
                            Recommends: libgl1-mesa-glx:i386
                            Recommends: libgl1-mesa-dri:i386

Output of sudo apt-get check :

Reading package lists... Done
Building dependency tree       
Reading state information... Done

How can I fix it ?
I use Ubuntu 12.04 64-bit .

share|improve this question
    
Why you need the ia32-libs package? Could you edit your question and add the output of sudo apt-get check? –  Braiam Sep 24 '13 at 19:50
    
@ Braiam, Thanks a lot for your answer. I need it for android development Tools (ADT). The output added ;) –  lichking Sep 24 '13 at 19:54
    
Which? I see 64-bits bundles everywhere. ATD and only SDK has 64-bits version, why are you trying to use 32bits? developer.android.com/sdk/index.html –  Braiam Sep 26 '13 at 14:16

1 Answer 1

Install both the ia32-libs-multiarch and the ia32-libs at the same time. If that fails, purge the ia32-libs you installed, and then try the two packges together.

share|improve this answer
    
unfortunately didn't worked . –  lichking Sep 25 '13 at 5:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.