Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm a sudoer on my workstation and also have the root password, but the Ubuntu Software Center doesn't let me install as it only lists a bunch of other users that are able to authenticate.

How do I grant myself the org.debian.apt.install-or-remove-packages "Action" that the details suggest I need? Some other post pointed me to /usr/share/polkit-1/actions/org.debian.apt.policy, but nothing in there is specifically referring to the four other users that the Authenticate dialog lists.

As an aside (not really the answer I'm looking for, but still of-interest), is there some way to get a package name from the Software Center that I can then install with apt-get via the prompt?

share|improve this question
    
How do you know you're a sudoer? If you can sudo to root, have you tried editing etc/sudoers and giving yourself all priveledges? Note: don't do that on a system you don't own. –  Wutaz Sep 24 '13 at 21:01
    
@Wutaz $ groups includes sudoers, among others, and I can sudo. Is there some other kind of sudo? –  Nick T Sep 24 '13 at 21:47
    
The sudo/sudoers/admin/coolguys group doesn't actually affect priveledges. It is usually used as a convenient way to grant them through the etc/sudoers file. It's that file that allows or denies specific actions. So if the sudoers group isn't in the file, it's meaningless to be a member of it. Also, you can sudo to an unpriveledged user if you want to; root is just the default. –  Wutaz Sep 24 '13 at 21:59
    
Ah. /etc/sudoers has %sudo ALL=(ALL) ALL, %sudoers ALL=(ALL) ALL, and %admin ALL=(ALL) ALL lines in it. Suspiciously, getent group admin listed the same four people that showed up in the authentication window, adding myself to that group (which other sources seem to say is identical to sudoers) solved the problem. –  Nick T Sep 24 '13 at 22:54
add comment

1 Answer

Adding my user to the admin group solved the problem, seems hacky (not really addressing the core problem), but it works. The four users listed in the Software Center dialog were the same that appeared in getent group admin.

sudo usermod -a -G admin nickt
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.