Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to connect my laptop to the Internet, I have an Internet cable attached and I select "additional drivers" from the system settings as I have read elsewhere. I get 2 drivers to install, one Broadcom STA Wireless Driver and a Software Modem. I try to install them (while I have Internet on the laptop), I put my password as required but I get these errors: When I try to install the Broadcom I get: Sorry, installation of this driver failed.

Please have a look at the log file for details: /var/log/jockey.log

When I try to install the Software Modem I get this:
SystemError: E:Unable to correct problems, you have held broken packages.

I've tried everything I read to get this working properly but I failed. Please be lenient as it's my first ever attempt on Ubuntu :P

Thank you

share|improve this question

You probably have the Broadcom 4311 wireless chip, so the b43 driver, supplied by default will work just fine. All you needed to do was supply the firmware for it by installing package linux-firmware-nonfree. You may install the packge now, but if things don't work, then you really have to clean out all the STA stuff which is interfering. Search for 4311 wireless, and you should find numerous detailed solutions.

share|improve this answer

I am 5 questions before you trying to enable wireless on a Acer 2480. I was able to get the wireless going on the 2480 by doing what is said here Hope this helps you if you have not tried this yet

share|improve this answer

You mentioned "When I try to install the Software Modem I get this: SystemError: E:Unable to correct problems, you have held broken packages."

You need to clear up the broken packages first.

To fix broken packages Open up Synaptic

Choose Edit > Fix Broken Packages from the menu.

Choose Apply Marked Changes from the Edit menu or press Ctrl + P.

Confirm the summary of changes and click Apply. 
share|improve this answer

Maybe answering a bit late, but I had the same issue when I let Ubuntu choose the best mirror server for its repositories updates, after a few minutes of a fresh install. So, I then just changed the repository mirror to the Main one and was able to download and activate the video driver I wanted. Maybe this works on some "rare" locations or situations, but trying such a subtle change won't hurt anyone, I guess.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.