Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I previously tried to update to 3.2.0.36-linux-generic but this was broken for some reason so every time I restart my server I have to boot 3.2.0.35-linux-generic.

When I try sudo apt-get upgrade I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run ‘apt-get -f install’ to correct these.
The following packages have unmet dependencies.
 linux-server : Depends: linux-headers-server (= 3.2.0.36.43) but 3.2.0.53.63 is installed
E: Unmet dependencies. Try using -f.

When trying sudo apt-get -f install I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  linux-image-3.2.0-53-generic linux-image-server linux-server
Suggested packages:
  fdutils linux-doc-3.2.0 linux-source-3.2.0 linux-tools
The following NEW packages will be installed
  linux-image-3.2.0-53-generic
The following packages will be upgraded:
  linux-image-server linux-server
2 upgraded, 1 newly installed, 0 to remove and 357 not upgraded.
8 not fully installed or removed.
Need to get 0 B/38.6 MB of archives.
After this operation, 150 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
(Reading database ... 420239 files and directories currently installed.)
Unpacking linux-image-3.2.0-53-generic (from .../linux-image-3.2.0-53-generic_3.2.0-53.81_amd64.deb) ...
Done.
dpkg: error processing /var/cache/apt/archives/linux-image-3.2.0-53-generic_3.2.0-53.81_amd64.deb (--unpack):
 failed in write on buffer copy for backend dpkg-deb during `./boot/config-3.2.0-53-generic': No space left on device
No apport report written because the error message indicates a disk full error
                                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.2.0-53-generic /boot/vmlinuz-3.2.0-53-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.2.0-53-generic /boot/vmlinuz-3.2.0-53-generic
Errors were encountered while processing:
 /var/cache/apt/archives/linux-image-3.2.0-53-generic_3.2.0-53.81_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I have tried removing kernels to free space on boot device but when trying sudo apt-get autoremove I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run ‘apt-get -f install’ to correct these.
The following packages have unmet dependencies.
 linux-server : Depends: linux-headers-server (= 3.2.0.36.43) but 3.2.0.53.63 is installed
E: Unmet dependencies. Try using -f.
share|improve this question
1  
Use apt-get update first. –  Braiam Sep 26 '13 at 14:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.