Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu-Gnome 13.04. Gnome 3.6.

I have three keyboard layouts: Us, Dvorak and Hindi WX. All the keyboard shortcuts in all categories (system, windows, etc.) work ONLY when US layout is selected.

Except shortcuts that use letters that are mapped to the same key in Dvorak and US layout (A and M) and shortcuts that do not involve an alphabet. So, Super M works and so does Alt-Control-1 defined in Custom category.

How can I get the shortcuts to work in all layouts?

share|improve this question

1 Answer 1

I just encountered this exact problem, and I was able to resolve it by disabling (using Backspace) and then entering the keybinding again in

System Settings -> Keyboard -> Shortcuts.

It appears to be tied to the keyboard layout I have enabled when I set the keybinding, and I have to go through this process every time I change keyboard configurations. Obviously, this becomes tedious if I switch keyboard configurations often. I have not found a workaround for automating this yet.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.