Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

SYSTEM: 4GB RAM; 500GB DISK I have tried some of the solutions I have seen about this error and none have helped. Here is the history: 1. I have been running 12.04 LTE for about a year now with no problems. Last week I booted and got error "Checking battery state ... [OK]" upon boot. I could do ctrl-alt-f1 and get to a terminal, so i tried some remedies online (e.g. reinstalling nvidia), and none helped. I finally bit the bullet and rebuilt my system from scratch.

  1. I was about 80% through restore and boot my system and upon boot got error "Could not write bytes: broken pipe" and could go no further unless i go to safemode (which is read-only). I tried memory check and fsck, and both came up clean. Bit bullet again and went for restore. I thought maybe my HDD was too hot, so I made sure it has better ventilation.

  2. I was about 95% through restore and boot my system and upon boot got error "Could not write bytes: broken pipe" again. Bit bullet again and went for restore. Argghh!

In both cases I had a thumb drive with nothing but a simple text file, so I don't think that was an issue. In both cases I did a clean reinstalls. The only way I can boot now is in safe mode, or booting to install thumb drive.

If anyone knows the cause or fix, please help!

Thanks, Doug

share|improve this question
    
Good day Doug, I have more or less the same problem than you have, and have done more or less the same things to try and resolve it. I am fairly unfamiliar with Ubuntu so I cannot resolve your problem but I have seen in one of the threads that there is a log file you can run through that indicate errors. This file is found in var/log/ and the file name is Xorg.0.log. Now I have seen guys that review this file and can pick up from that what installation packages have errors. Then they reinstall those packages and it works. I have tried to run through my own but I cannot gather the errors. Maybe –  Marius Apr 12 at 7:25
    
possible duplicate of Ubuntu not booting: "Could not write bytes: broken pipes" –  Eric Carvalho May 10 at 18:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.