Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed ubuntu 12.04 on my macbook pro 8,2 and my wireless card is bcm4331. I tried many things and it worked for a while actually. However, now it is not working again. It is enabled, but no wireless networks are discovered.

$ lsmod |grep b43
b43                   392109  0 
mac80211              630977  1 b43
cfg80211              525244  2 b43,mac80211
ssb                    57842  1 b43
bcma                   41244  1 b43

$ lspci -nn | grep Network
03:00.0 Network controller [0280]: Broadcom Corporation BCM4331 802.11a/b/g/n [14e4:4331] (rev 02)

$ lshw
...
  *-network
       description: Wireless interface
       physical id: 2
       logical name: wlan0
       serial: e0:f8:47:15:d3:70
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=b43 driverversion=3.8.0-30-generic firmware=666.2 link=no multicast=yes wireless=IEEE 802.11bg

Thanks.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.