Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to install Ubuntu 13.04 alongside Windows 8. I had shrunk the Windows partition 21 GBs, and did not format it. Then, I disabled fast boot and secure boot from the BIOS, and made the UEFI: sandisk with the 13.04 copied with Universal USB installer, the first priority for boot.

When Ubuntu installer loaded, I chose Install Ubuntu, and then chose install alongside ubuntu.

When it restarted, GRUB showed up with no problem, but when I try to load Ubuntu, I get no GUI. I tried startx, but it told me no screens found.

When I try to boot into Windows 8, by choosing it from GRUB loader, It gives me the following errors:

error: can't find command "drivemap"
error: invalid efi filepath

But, when I go to the BIOS, the boot options have changed to include Ubuntu, and also the already existing Windows Boot Manager. I choose Windows Boot Manager again, which, upon restart, bypasses GRUB, and loads directly into Windows 8.

I am not sure whether these are two separate problems so I wrote them both in a single question.

The laptop I use is Samsung ATIV book 9, with 128 GB SSD.

share|improve this question

Ok, I am very sorry. As I said, I had a little trouble with the 13.04 (it is also an unstable version). Just got with the Long Term Support version 12.04 LTS. This version is very stable and no problems on it. I can't propose any solution because I haven't tried deeply 13.04 so far. But if I find the solution to your problem, I'll let you know.

12.04 is stable and supported until 2017. If you try to install it alonside Windows 8, format a partition (to ext2 or ext4) then install Ubuntu on it. It is advided to use the swap partition (1GB) if you computer has less than 4GB. After installing, you should have GRUB and then boot ubuntu. Any trouble with 12.04, tell me

share|improve this answer
I am convinced it's not the choice of the Ubuntu version that caused the problem. The laptop seems to have a VERY weird BIOS that today an expert could not figure out. I will give wubi a try now. – sodiumnitrate Sep 25 '13 at 18:01

This is why your windows option fails: The Ubuntu grub has a BIOS friendly menu item created by os-prober, which generates all the non-Ubuntu boot menu items. os-prober is not UEFI-ready (late-2013). Your system is UEFI and you will have to create your own menu item to boot windows, if you want to use Ubuntu grub2 to choose your OS, you can add menu items by editing this file: etc/grub.d/40_custom

add this menu item to it, by: sudo gedit etc/grub.d/40_custom

menuentry 'Windows 8' {
search --fs-uuid --no-floppy --set=root 28ED-4D40
chainloader (${root})/EFI/Microsoft/Boot/bootmgfw.efi

replace the 28E... with the UUID of your EFI partition. Find the UUID of the EFI partition using sudo blkid command in linux terminal. if you want windows to be at the top of the list, just rename 40_custom to 09_custom.

Then run sudo grub2-mkconfig -o /boot/grub/grub.cfg to regenerate the file that holds the bootloader menu items. You can also customize the menu items completely.

Regarding the problem where Ubuntu doesnt seem to boot properly, I recommend running Ubuntu boot-repair after booting from a Ubuntu live USB. You can make the live USB in windows.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.