Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I wanted to use the most recent nvidia-319(I think) drivers so that Steam would stop complaining about my drivers. I selected the 319 drivers in the System Hardware menu and rebooted. The system hung on reboot for several minutes so I performed a hard-shutdown. After the system came back online, it prompted me for my MySQLServer login (its never done that before). I forgot the credentials so I hard-restarted again and this time it boots to a black screen with a flashing cursor on the top left. NOTHING THAT I TYPE IS SHOWN ON SCREEN. When I hit the power button, it says various things are shutting down/stopping and then the system turns off.

My question is how can I use a LiveCD to revert this driver change? Or is there another (better) method? This is the first time that I have broken my Ubuntu in 4 years :(

Thanks in advance.

share|improve this question

marked as duplicate by Braiam, Luis Alvarado Sep 24 '13 at 3:11

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Reinstalling your drivers to the current version will solve this:

You will have to boot normally, and when the black screen appears, press ctrl+alt+F1. Login, then use the following commands.

First remove all the old drivers:

sudo apt-get purge nvidia*

Then reinstall the current drivers:

sudo apt-get install nvidia-current

Reboot, and your're good to go!

sudo reboot
share|improve this answer
What options do I need to choose from the LiveCD to be able to gain terminal access? The flashing cursor does not show anything that I type. – V1GG3N Sep 23 '13 at 17:57
You shouldn't do this from the live cd, but from when you boot "normally". I've updated my answer. – Joren Sep 23 '13 at 18:39
This is what I get after trying to purge: E: Unable to locate package nvidia-bug-report.log.gz E: Couldn't find any package by regex 'nvidia-bug-report.log.gz' I then tried to install current, it said I was running the current version and gave me the option to remove unnecessary packages, which I did. Rebooted and same black screen with cursor. – V1GG3N Sep 23 '13 at 22:03

When I was using 12.04 with nvidia and had a problem I would edit grub and add nomodeset and boot into vessa and then reinstall nvidia drivers. Usualy worked for me.I had to use nomodeset to run cd also .

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.