Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Acer Aspire S3-391 ultrabook. It's Sandy Bridge i3-2377M CPU with appropriate integrated graphics. 320GB hard drive with 20GB cache SSD. I have Windows installed on the hard drive and Ubuntu 13.04 installed on the SSD.

Now, the problem I am having is exactly as described in the title. When the brightness under /sys/class/backlight/acpi_video0/brightness is set at 0, the backlight turns off. The screen is still powered and under camera flash, it's visible - i.e. the system is still working.

This is mostly a problem because the OS defaults to the lowest brightness on boot, leaving me to blindly type my password in and later adjust the backlight. Not horrible, I guess, but annoying enough to want to fix it.

Things I have tried: -Installing Intel drivers. They worked, but the backlight doesn't respond to Fn keys anymore and to get any backlight whatsoever I have to boot Ubuntu normally from recovery mode. Any tips on uninstalling this? Otherwise I was just going to reinstall Ubuntu and start at the original issue.

-Using xbacklight. It does modify the backlight, as expected, but I can't set the minimum above 0.

-Modifying the brightness setting under /sys/class/backlight/acpi_video0. This is the correct path - the backlight attribute changes with brightness modifications. When doing a ls here, there seems to be a max brightness attribute, but no minimum.

So basically, what I need to know: -How to uninstall the Intel drivers, i.e. replace them with the Ubuntu default for HD3000 integrated graphics (is this the noveau I keep hearing about?) -How to restrict the system from entering a brightness level of 0.

Thanks in advance!

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.