Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just decided to now swap from Win to Ubuntu. Now after the install of the latest Ubuntu (13.04), the animations of the Desktop (just as open the dash-board) are very laggy and slow. I searched around the internet, but nothing of the answers fits my problem, since my Hardware is at least sufficient to render such animations. Here my specs:

  • AMD Athlon II X4 640
  • XFX R7770
  • 8GB DDR3

The Hardware can't be the problem since it's running well under windows. I also updated Ubuntu to the current, and I'm using the xorg radeon driver. I also tried to edit the xorg.config, but it seems that won't work for me (I also read somewhere it's not used anymore ?!). And interesting fact is that Ubuntu doesn't detect my monitor (Medion) AND does only support 1024x768 and lower resolution. Maybe I'm to stupid to search for but I didn't come to a solution on my own.

My question is, does someone knows how I could fix this laggy GUI or at least know whats the source of my problem ?

EDIT: Sorry, forgot the output of sudo lspci -nnk | grep -A10 VGA:
02:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Cape Verde XT [Radeon HD 7770 GHz Edition] [1002:683d]
Subsystem: XFX Pine Group Inc. Device [1682:3232]
Kernel driver in use: radeon

02:00.1 Audio device [0403]: Advanced Micro Devices [AMD] nee ATI Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series] [1002:aab0]
Subsystem: XFX Pine Group Inc. Device [1682:aab0]
Kernel driver in use: snd_hda_intel

03:06.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller [10ec:8185] (rev 20)
Subsystem: Planex Communications, Inc Device [14ea:8225]
Kernel driver in use: rtl8180

share|improve this question
    
Could you edit your question and add the output of sudo lspci -nnk | grep -A10 VGA? –  Braiam Sep 23 '13 at 15:06

1 Answer 1

According to the xserver-xorg-video-radeon package description for 1:7.1.0-0ubuntu2, it does not support the Cape Verde/Pitcairn chipset, which is used in the Radeon HD 7700 series cards. I just found this out the hard way when KDE wouldn't enable OpenGL compositing.

This bug has more info: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/1209397

If you upgrade to 13.10 Saucy, it will probably work "out of the box." If you stay with Raring, you might be able to install and/or build packages from Saucy to enable 3D support.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.