Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am working with an application using a touch screen. For this, I need Onboard (the on-screen keyboard) to open from Ubuntu's startup time with a fixed width and height. I also need to get a reserved screen position for placing Onboard (which means that Onboard should not be in front of any application windows). I'm using Ubuntu 12.04 LTS.

Onboard was not installed in my system. I installed it by typing sudo apt-get install onboard in the terminal. It doesn't work properly. Now the system shows Onboard when I type onboard in the terminal. Onboard closes itself when I close the terminal.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Open Gedit and type:

#!/bin/bash
# you can change the size of the window below (1000x300)
onboard -s 1000x300

Now save this file somewhere as filename.sh and open a terminal window. Navigate to this file location by using:

cd /home/user/blah/blah/../filename.sh

When you get there type in

sudo chmod a+x 'filename.sh'

(quotes are there for avoiding space character problems). Now you've made it an executable bash script. Open 'gnome-session-properties' from terminal and click on Add.

Name: Onboard
Command: "Browse to the file location"
Comment: Onboard on startup

Click add and you're done! Logout and login to see if it worked.

share|improve this answer
    
Thanks brother,It works. But it shows only on login time so that i can enter my User_password with Onboard. I lost it when i logged in to my account. can i do anything more? –  sijovw Sep 23 '13 at 8:06
    
Is "Start Onboard hidden" checked in Onboard preferences? That might be it; Because it works quite fine for me. –  Python Student Sep 23 '13 at 8:24
    
No. I took Onboard Preferences. But in the 'general' tab the only unchecked thing is this "Start Onboard hidden". –  sijovw Sep 23 '13 at 9:19
    
Thanks Python, i did the same thing again as you said and it works fine.Thank you very much. –  sijovw Sep 23 '13 at 10:01

To auto start Onboard, go to Universal Access and select Typing, then turn On Screen Keyboard on.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.