Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 13.04 alongside windows 8 (efi mode) and now I want to go to a read-write access of the efi boot partition.

For secure boot to work, I installed the Linux Foundation's PreLoader. Then I enabled root account login to access the efi boot partition. I have copied the boot loader, but now the efi boot partition mounts as read-only.

When I try to change the folder permissions, it says:

Error setting permissions:Read-only filesystem

I have already tried the following command in root:

mount -o remount,rw /folder1/folder2/targetFolder

It is still read-only.

How to fix this?

share|improve this question

2 Answers 2

i figured it out my self ... i used chkdsk command in windows 8 and it repaired the partition.

thanks if anybody took pain to solve this .. i would have deleted this question the same day i posted it here but i don't know how to. sorry

share|improve this answer
    
Mark this as the answer. –  Jared Burrows Feb 11 at 14:26

Your problem was most likely caused by a new Windows 8 feature called "fast startup." This feature turns a Windows shutdown operation into a suspend-to-disk function, which in turn means that the filesystems are not properly unmounted, which means that they cannot be safely mounted in any other OS. Thus, on systems that dual-boot with Windows 8, it's IMPERATIVE that fast startup be disabled, as described here:

http://www.eightforums.com/tutorials/6320-fast-startup-turn-off-windows-8-a.html

share|improve this answer
    
i knew about the windows fast boot issue with linux and already figured the way around(created a shortcut to command line shutdown that shutdows the windows in old way) and can ACCESS THE DRIVES in UBUNTU.. but i ran fsck in ubuntu and there was some cluster mismatch issue and another error found during ubuntu recovery mode a superblock could not be read. –  user195216 Sep 24 '13 at 9:35
    
and i used the chkdsk in cmd prompt that repaired the efi boot partiion –  user195216 Sep 24 '13 at 9:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.