Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Last night I was having a problem with reinstalling ubuntu through wubi on a PC, I had installed it first, and booted into it after the installer was done, through an automatic reboot into ubuntu option, it worked fine, but after few minutes it just froze (lack of a better processor) so I did a hard reboot (pressed the hardware power off button) and went into ubuntu again and it gave me an error saying error: file could not be found and I booted into windows made sure everything was working, which it was, and then shut it down and booted ubuntu with the same error message, so I went into windows and uninstalled ubuntu by going to control panel, uninstall a program, and then I uninstalled ubuntu, then I ran the installer again but it says the file ubuntu in C: already exits, so I went to Windows explorer and tried to remove the ubuntu file, but it kept saying that I do not have permission to use it's contents even when I am an admin?

share|improve this question

1 Answer 1

It's corrupted. That's why you don't have permission. When it 'froze', it was not 'frozen' - just your screen probably. The hard reboot corrupted the root.disk most likely.

So, two things. First with linux you can often safely reboot even if the screen is frozen via some special keys that the kernel responds to: https://en.wikipedia.org/wiki/Magic_SysRq_key

That would have avoided the problem in the first place.

The second thing is that it likely froze due to some hardware incompatibility. Commonly this is that your graphics driver isn't adequately supported by the open source drivers installed by default with Ubuntu. So you should boot with nomodeset and install closed source drivers instead. It could be something else, e.g. wireless card, as well, so it's a good idea to research your computer's specs via Google (w/Ubuntu).

Finally, to fix the problem you have now, you will need to run chkdsk /f from Windows. You can either run it from a repair command prompt (booting from a repair CD) or you can request it from the drive tools menu - since it's on C:\ you need to reboot to complete it. After that you should be able to remove the C:\ubuntu directory.

This answer shows how to run chkdsk (but it's written from the perspective of recovering a Wubi install, not removing it). Note that when chkdsk fixes the corruption it could place the whole root.disk in the hidden \found.000 directories so you might need to find these are remove them to recover all your disk space.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.