Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Whenever I try to run apt-get install openssh-server I get the following errors:

root@ubuntu-phablet:/home/hablet# apt-get install openssh-server
W: Not using locking for read only lock file /var/lib/dpkg/lock
E: Unable to write to /var/cache/apt
E: The package lists or status file could not be parsed or opened.
share|improve this question
Exactly the same error – user195123 Sep 22 '13 at 14:10
Same error for me doing same thing - ubuntu 11.04. – Malee Sep 22 '13 at 14:13
@Malee 11.04 is end of life, you can't get help for 11.04 here because of that. Upgrade to 12.04 or newer, or to a supported release, and then we can help you fix it. – Thomas W. Sep 22 '13 at 16:35
Ubuntu touch does not have the software center yet and updating is terminal only, which i did not do as i tried to install openssh. – user195123 Sep 22 '13 at 17:47
Ok since i did not change too much yet, do you think formatting my storage and reflashing ubuntu helps? – user195123 Sep 22 '13 at 19:00

5 Answers 5

Try making it writable and reboot:

touch /userdata/.writable_image

Edit: When you build it use the --pending switch Updates to phablet-flash

Edit: System images now the recommended way to deploy and update Ubuntu Touch

share|improve this answer
This answer is no longer relevant. – popey Mar 20 at 8:46

OpenSSH server is now (as of 13-Sep-2013) pre-loaded with Ubuntu Touch install. However, it is also disabled by default. You also don't want SSH operating from root.

You need to type the following, using a USB connection to the device:

adb shell
su - phablet
sudo tee /etc/init/ssh.override < /dev/null

To revert to disabled

echo "manual" | sudo tee /etc/init/ssh.override

UPDATE: (09-Mar-2014)

The answer above is no longer current.

  • As of early March 2014, while the file /etc/init/ssh.override still exists, changing its contents does not allow SSH (actually the sshd daemon) to run on startup.

  • The recent builds (tested for 226, but possibly earlier) now support a new meta-flag persist.service.ssh, to allow SSH (sshd daemon) to re-start on startup.

Get to command prompt (on device)

adb shell
su - phablet

Start SSH, and set flag

sudo service ssh start
sudo setprop persist.service.ssh true

Restart device

sudo reboot

The SSH daemon should auto-start

sudo service ssh status

To disable SSH auto-start, change the flag:

sudo setprop persist.service.ssh false
share|improve this answer
why do you need to sudo everything after going su -? – Octopus Jan 16 at 9:30
The line su - phablet changes the user to phablet, not super-user. It is generally best practice to use least privilege, so as to be less vulnerable to attack. – david6 Jan 16 at 9:55
this answer needs updating, look at @ogra's – sergiusens Mar 25 at 17:54
Will need to review and try that method first. – david6 Mar 25 at 20:03

With the official final release Ubuntu for Phones ships the "android-gadget-service" tool with which you can manage adb, mtp, USB tethering and ssh.

Connect your device via USB, enable Developer Mode in:

"System-Settings->About This Phone->Developer Mode"

...and run (from your PC, make sure to have the phone screen unlocked, else adb will refuse to let you in):

adb shell android-gadget-service enable ssh

Copy your public key to the Phone:

adb shell mkdir /home/phablet/.ssh
adb push ~/.ssh/ /home/phablet/.ssh/authorized_keys
adb shell chown -R phablet.phablet /home/phablet/.ssh
adb shell chmod 700 /home/phablet/.ssh
adb shell chmod 600 /home/phablet/.ssh/authorized_keys

Now you can look up your IP on the phone and use ssh to connect:

adb shell ip addr show wlan0|grep inet
ssh phablet@<IP from above command>
share|improve this answer
Works great, but the last command will show no IP if the network interface is not named wlan0. Mine was wlan2 for some reason. – Cos64 Mar 28 at 6:32
The command: adb push ~/.ssh/ /home/phablet/.ssh/authorized_keys Gives me: cannot stat '/home/tenleftfingers/.ssh/': No such file or directory – TenLeftFingers May 13 at 17:05

To activate ssh access entirely over wifi, without developer mode on the phone, without any special tooling on your computer and without using USB:

  1. If you don't already have an ssh keypair, type ssh-keygen on your computer and follow the instructions to generate one.
  2. Install the Terminal app on the phone from the App Store.
  3. Open a Terminal and type (this is easier with the phone in a landscape orientation):

    sudo setprop persist.service.ssh true
    mkdir -pm700 ~/.ssh
    ip addr
    nc -l 1234 > ~/.ssh/authorized_keys

    (the last command will hang; this is expected)

  4. Look for your phone's IP address in the Terminal as returned by the ip addr command above.

  5. On your computer, type (replacing with your phone's IP address from above):

    nc 1234 < ~/.ssh/

    If successful, the last command on your phone's Terminal will now succeed.

  6. On your computer, type (again replacing with your phone's IP address from above):

    ssh phablet@
  7. If your phone's IP address changes, you will need to use ip addr in the Terminal app on your phone again and adjust your ssh command accordingly.

share|improve this answer
Very informative answer as it does away with the adb shell and USB cable. Two thumbs up! – Stunts Apr 3 at 11:22
Indeed Veryvery usefull answer. +2 – zloster Jun 6 at 7:33
@ogra (who knows better than me) tells me that sudo android-gadget-service-enable ssh superceded sudo setprop persist.service.ssh true and should be used instead, but I haven't tested this. – Robie Basak Jun 23 at 9:04

Install Ubuntu SDK and click "Open SSH connection do the device" in the devices panel. Bonus: you won't resist to writing a new Scope...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.