Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I tried using sudo apt-get install apt-transport-https but it doesn't work for me.

sudo apt-get update
E: The method driver /usr/lib/apt/methods/https could not be found.

sudo apt-get install apt-transport-https

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package apt-transport-https is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'apt-transport-https' has no installation candidate

My etc/apt/sources.list

# deb cdrom:[Ubuntu 13.04 _Raring Ringtail_ - Release amd64 (20130424)]/ raring main restricted

deb raring main restricted
deb-src raring restricted universe multiverse main #Added by software-properties

## Major bug fix updates produced after the final release of the
## distribution.
deb raring-updates main restricted
deb-src raring-updates restricted main multiverse universe #Added by software-properties

deb raring universe
deb raring-updates universe

deb raring multiverse
deb raring-updates multiverse

deb raring-backports main restricted universe multiverse
deb-src raring-backports main restricted universe multiverse #Added by software-properties

deb raring-security main restricted
deb-src raring-security restricted main multiverse universe #Added by software-properties
deb raring-security universe
deb raring-security multiverse

## Uncomment the following two lines to add software from Canonical\'s
## \'partner\' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb raring partner
deb-src raring partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb raring main
deb raring partner
deb-src raring partner
deb-src raring main
share|improve this question
Tried the method on that link but I can't make it work. – mlalbertoii Sep 22 '13 at 8:11
all the other methods ? – Raja Sep 22 '13 at 8:14
Which version of Ubuntu do you run? Can you paste your /etc/apt/sources.list? – tlo Sep 22 '13 at 11:06
I'm a newcomer to Linux, please excuse my dumbness. Here's my source list. – mlalbertoii Sep 22 '13 at 12:17

2 Answers 2

After looking at your sources.list, I still don't understand why apt is in need oft https (maybe some additional sources in /etc/apt/sources.list.d?), but to get apt-transport-https installed you can do this:

sudo wget$(dpkg-architecture -qDEB_HOST_ARCH).deb && sudo dpkg -i apt-transport-https_0.9.7.7ubuntu5_$(dpkg-architecture -qDEB_HOST_ARCH).deb)

The dpkg-architecture command is used to determine the architecture of your system. You could also replace it with i386 or amd64.

share|improve this answer

I was not able to get the exact command line variant working, but I was able to browse to

Where I located the latest version of the apt-transport-https, in my case the


I then downloaded it, double clicked the deb file and installed it. Now everything seems to work correctly again.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.