Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used a pre-written shell script to install steam and it supplied me with libc-ubuntu.deb file. When I dpkg the deb file it says this:

sudo dpkg -i libc6_2.15-0ubuntu10.2_i386.deb 
(Reading database ... 223764 files and directories currently installed.)
Preparing to replace libc6 2.15-0ubuntu10.2 (using libc6_2.15-0ubuntu10.2_i386.deb) ...
Unpacking replacement libc6 ...
dpkg: dependency problems prevent configuration of libc6:
 libc6 depends on libc-bin (= 2.15-0ubuntu10.2); however:
  Version of libc-bin on system is 2.15-0ubuntu10.4.
dpkg: error processing libc6 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libc6

How can I install this file properly?

share|improve this question
1  
Why not installing steam using apt-get install steam? –  Braiam Sep 24 '13 at 16:10

1 Answer 1

You'll need libc-bin version 2.15-0ubuntu10.2 to go along with your libc6 2.15-0ubuntu10.2 package. You probably need a few others too- if you have libc6-dev or libc6-dbg, those also need to match the libc6 version exactly so they'll need to be downgraded at the same time.

2.15-0ubuntu10.2 is the version of these packages in Ubuntu Precise, and 2.15-0ubuntu10.4 is the current version in precise-updates. So one way for you to get all those packages (since you surely have the standard precise apt sources too) is:

apt-get install $(for pkg in libc6 libc-bin libc6-dev libc6-dbg; do \
    dpkg -s "$pkg" &> /dev/null && echo "${pkg}=2.15-0ubuntu10.2"; \
done)

You might have other packages which require an exact libc6 version.

The changes between 2.15-0ubuntu10.2 and 2.15-0ubuntu10.4 can be found here.

However, it's not at all obvious to me that you really actually need the ...10.2 version. It's more likely that whoever made your script just grabbed the version of libc6 that was current in ubuntu at the time and sent it out as "libc-ubuntu.deb". But the version of libc6 you already have is, in all likelihood, perfectly fine for the binaries in their package. Debian and Ubuntu package updates to stable distributions, like Precise, are extremely careful to avoid making changes to library ABIs or APIs or other documented interfaces, so if the ...10.2 version works and the ...10.4 version doesn't, that's probably a bug that Ubuntu will want to know about. I would try just installing your Steam package(s?) without bothering with the libc-ubuntu.deb file.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.