Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just got my new laptop, a lenovo ideapad u430, but I can't install ubuntu. I'm not a complete noob, I've installed ubuntu in other computers before, but this one is giving me problems. I got it to boot from the usb (13.04) but the first installation screen is barely visible, very, very dark, and nothing seems to work. If I press enter when the orange screen with the small keyboard logo appears, it gives me a menu to either install or use ubuntu, but if I choose any of the options it tries to start and then just freezes and the screen is either black or show some logs of what it was doing. If I try to install the 13.10 I get a black screen after the purple screen with the small keyboard icon on the bottom.

I then tried and managed to install ubuntu 12.04, it seems to work more or less, but when I upgraded the computer boots to a black screen, then only way to make it work is by booting with the 3.2 kernel. I reinstall ubunte 12.04 and as soon as I updated the kernel files same black screen.

I would love to get ubuntu 13.10 working, but I need at least to be able to use the new kernels.

These are the specs of my laptop: http://www.notebookcheck.net/Review-Lenovo-IdeaPad-U430-Touch-Ultrabook.100623.0.html

share|improve this question
    
I just picked up one of these u430's from Best Buy as well, and I am really looking forward to getting some Ubuntu on it. Any word on touch screen support? –  stat30fbliss Oct 9 '13 at 16:22
    
The screen works just fine, you simply have to press the brightness button to increase brightness and you'll have an image. What noboby has been able to figure out is the nvidia card. –  Matías Guzmán Naranjo Oct 10 '13 at 17:48

2 Answers 2

up vote 3 down vote accepted

To answer my own question. Just hit the brightness button on the laptop till it shows an image.

share|improve this answer

I had the same issue as you had. But I wasn't trying to install Ubuntu on the laptop, I was just trying to run it from a USB drive to test it first.

I tried too many things. Strangely Ubuntu 12.04 with kernel 3.2 works but without wireless :(, while 13.10 ... just a black screen.

The only way I was able to fix this is while booting up from the live Ubuntu 13.10 USB drive. I pressed F6 and selected from the options menu acpi=off. This enabled me to boot Ubuntu 13.10 perfectly and the wireless was working great.

I haven't tried to install it yet, and hence it's going to be different for an installed Ubuntu. You'd probably need to set acpi=off to the kernel boot command line in /etc/default/grub. Here's a link on how you might do it. Again I didn't test it.

http://ubuntuguide.net/turn-off-acpi-ubuntu-grub2

I hope this helps! Thanks.

share|improve this answer
    
Thanks, it turned out to be really simple, you just have to increase the brightness with the keyboard. I feel silly now. –  Matías Guzmán Naranjo Sep 28 '13 at 9:09
    
Disabling ACPI on a mobile device? Really? That disables all power management, which you really don't want. –  gertvdijk Oct 7 '13 at 20:12
    
@MatíasGuzmánNaranjo Post that as an answer and mark that as correct instead. –  gertvdijk Oct 7 '13 at 20:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.