Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Asus N750 has an external subwoofer, but it doesn't work on ubuntu. I tried to solve the problem as it was written in http://askubuntu.com/questions/189304/no-sound-from-external-subwoofer-sonic-master-on-an-asus-n76vm, but it doesn't work. In extra-hdmi.conf i added

[General]
auto-profiles = no

[Mapping analog-surround-21]
device-strings = surround40:%f
channel-map = front-left,front-right,lfe,lfe
paths-output = analog-output analog-output-speaker
priority = 7
direction = output

and reboot, the only sound device is "dummy input".

Can you help me to solve this problem?

lspci -k | grep -i -A2 "multimedia\|audio" output:

00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
        Subsystem: Intel Corporation Device 2010
        Kernel driver in use: snd_hda_intel
--
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 04)
        Subsystem: ASUSTeK Computer Inc. Device 129d
        Kernel driver in use: snd_hda_intel
share|improve this question
    
I'm having the same problem. Did you resolve the issue. Sorry that it isn't a comment but I don't have enought rep. –  Pawel Dec 10 '13 at 4:19

1 Answer 1

up vote 0 down vote accepted

I have found a temporary solution.

  1. sudo apt-get install alsa-tools-gui
  2. run hdajackretask
  3. Select a codec: ALC668
  4. Set "show unconnected pins"
  5. Find pin 0x1a
  6. Set "override" -> Internal speaker(LFE)
  7. Click install boot override
  8. In /etc/modprobe.d/alsa-base.conf add line options snd-hda-intel model=asus-mode4. It allows you to control the volume of the subwoofer via alsamixer
  9. Reboot

I still have problems with audio profiles(no 4.0 and 2.1 configurations in kmixer), but the subwoofer works now. The only problem is that it is now muted when i plug in headphones.

share|improve this answer
    
It is not working for me (Ubuntu 13.10). Why the pin 0x1a? Do you have some source? –  Michal Kováč Feb 7 at 18:06
    
No, i don't have any source. I have experimented with different pins and configurations. Is subwoofer displayed in alsamixer? Did you turn it's volume on(on mine computer it was muted by default)? –  Yauhen Vasileusky Feb 11 at 6:05
    
I think the subwoofer is not visible. I don't know whether it is muted, there is no hardware button and alsamixer don't display it either. In alsamixer, when I press F6 (=Select sound card), two of them are visible and here are their playback items: HDA Intel MID: S/PDIF, S/PDIF 1, S/PDIF 2; HDA Intel PCH: Master, Headphone, Speaker, Bass Speaker, PCM, Mic, Mic Boost, S/PDIF, S/PDIF, Default PCM, Auto-Mute Mode –  Michal Kováč Feb 11 at 11:38
    
Bass Speaker is a subwoofer. You need to select PCH device and unmute Bass Speaker if it is muted. Then you have to select appropriate audio profile (Analog stereo in my case) and make it as a default. –  Yauhen Vasileusky Feb 11 at 17:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.