Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have AMD mobility 6000 series graphics card along with intel sandy bridge (2nd gen) hd 3000. AMD graphics with catalyst driver is fine, but I can not get intel graphics card to get working with fairly decent performance. I have tried the xorg-video-intel drivers from mesa 9.1 to mesa 9.2 through different methods (intel's graphics installer, oibaf ppa, xorg-edgers in ubuntu 13.04), elementary OS, arch etc.

In some cases the games start to lag little later, but the end result is pretty similar in all of them. Laptops heats up and the graphics can not keep up the gaming performance and starts to lag. It looks like a sluggish java application, where the garbage collector is not working. In one occasion, it completely halted my arch installation (I guess over heating).

I tried different sandy bridge related parameters in the linux line through /etc/default/grub. I also tried the semaphore options, but without any success. I have also gone with pure open source options (without installing catalyst drivers). In this case SNA is enabled, but the end result is similar to the UXA which is set when I use catalyst driver.

Since I don't have any options in bios to switch to a particular graphics card, I am unable to use radeon drivers, unless they properly implement dynamic switching while using graphics intensive applications. If I have to use open source drivers, I always turn off AMD graphics card using vgaswitcheroo. I am hoping wayland or Mir is going to solve this problem.

Intel graphics card was not like this always. I have played TF2 for hours on this graphics card. It did not lag this much before mesa 9.1. These days

i915_hangcheck_hung *ERROR* Hangcheck timer elapsed... GPU hung

is becoming a common thing. Is there something, I can do to bring back the performance, or should I rely on Intel's buggy driver and hope they will fix it some day.

Once in old days, I had lost the support for 845G, after which I had to be selective about my Linux installation. This time I don't want to give up intel hd 3000, just because Intel developers don't care about testing hd 3000 and go with 4000 and above instead.

Is there a tweak, settings in ubuntu that I can do to bring back the performance. If I want to downgrade to mesa version 9.0, can I do it. If so, how?

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.