Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I don't use the Music, Documents, Pictures, Video, and Trash folders often enough to warrant them an honorary place on the sidebar of Ubuntu's 13.04 default file manager "Files".

enter image description here

I would like to remove them, but the "Remove" item on the context menu is grayed out. Since Linux distros tend to be configurable I'm guessing there is a way around this.

The Gear menu doesn't seem to have any options to do this:

enter image description here

The Bookmarks menu looked helpful, but it still made no changes.

enter image description here

enter image description here

(This is after I removed all the Bookmarks I wasn't interested in.)

I have also tried the suggestion from this answer and commented out lines I don't want from user-dirs.dirs, but still no luck:

$ vim ~/.config/user-dirs.dirs
<edits>
$ xdg-user-dirs-gtk-update

How do you remove these default items from the sidebar?

share|improve this question
1  
@Arnold is perfectly right here. This answer there is still valid and its they way to go. It still is Nautilus being responsible for files in 13.04 Ubuntu. –  Takkat Sep 20 '13 at 19:39
    
@Takkat I just tried that answer, it didn't change the appearance at all. Have you tried this on 13.04? Also, if Nautilus is being used for files in 13.04, why does the File->About page say "Files 3.6.3"? –  Cory Klein Sep 20 '13 at 19:43
    
I was able to fix it finally by following this comment. –  Cory Klein Sep 20 '13 at 20:16
1  
Great! I edited the answer to add the comment. This makes it more prominent ;) –  Takkat Sep 20 '13 at 20:34
    
@Takkat 's answer on this link perfectly works on my 13.04 x64 askubuntu.com/questions/79150/… –  Arnold Sep 21 '13 at 5:15
add comment

marked as duplicate by Takkat, Mateo, Eric Carvalho, Kevin Bowen, Warren Hill Sep 21 '13 at 7:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

Go to Bookmarks > Edit Bookmakrs... You will find further options to remove or edit given bookmarks(i.e Documents, Music, Videos etc.).

enter image description here

My image represents Ubuntu 12.04.3. In your Ubuntu, if you don't find Bookmarks menu, check if it's there under Gear icon (Top right).

share|improve this answer
    
Unfortunately in 13.04 there is no Edit Bookmarks menu available from the Gear icon or the menu bar. –  Cory Klein Sep 20 '13 at 18:39
add comment

The answer to this question is covered here.

You need to change the variables in .config/user-dirs.dirs to point to $HOME like this:

XDG_VIDEOS_DIR="$HOME"
share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.