Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My work laptop is running Ubuntu 12.10 (32-bit). Due to the need to be able to test our code in the same versions of PHP, Memcache, and a few other modules; I need to keep the PHP version right where they are at (for example PHP 5.3.x). However I would like to upgrade to my current OS version to Ubuntu 13.04.

Can I upgrade without worrying that Ubuntu will also upgrade the PHP package and other related packages? Or will it just do that whether I like it or not?

Thanks!

Edit: After running "sudo apt-get dist-upgrade -V" I get the following results:

The following packages will be REMOVED:
   libmemcached6 (0.44-1.1build1)
   php5-intl (5.4.6-1ubuntu1.4)
   php5-memcached (2.0.1-6)
   php5-xsl (5.4.6-1ubuntu1.4)
The following NEW packages will be installed:
   libjs-underscore (1.3.3-1ubuntu1)
   libmemcached10 (1.0.8-1)
   libmemcachedutil2 (1.0.8-1)
   linux-headers-3.5.0-40 (3.5.0-40.62)
   linux-headers-3.5.0-40-generic (3.5.0-40.62)
   linux-image-3.5.0-40-generic (3.5.0-40.62)
   linux-image-extra-3.5.0-40-generic (3.5.0-40.62)
The following packages have been kept back:
   php-apc (3.1.7-1 => 3.1.13-1)
The following packages will be upgraded:
   libmemcached-tools (0.44-1.1build1 => 1.0.8-1)
   linux-headers-generic (3.5.0.31.47 => 3.5.0.40.56)
   linux-image-generic (3.5.0.31.47 => 3.5.0.40.56)
   mercurial (2.6.1-1ppa1~quantal1 => 2.7-0ppa1~quantal1)
   mercurial-common (2.6.1-1ppa1~quantal1 => 2.7-0ppa1~quantal1)
   tortoisehg (2.8-0ppa1~quantal1 => 2.9-0ppa1~quantal1)
The following packages will be DOWNGRADED:
   libapache2-mod-php5 (5.3.10-1ubuntu3.6 => 5.3.10-1ubuntu3)
   php5-cli (5.3.10-1ubuntu3.6 => 5.3.10-1ubuntu3)
   php5-common (5.3.10-1ubuntu3.6 => 5.3.10-1ubuntu3)
   php5-curl (5.3.10-1ubuntu3.6 => 5.3.10-1ubuntu3)
   php5-gd (5.3.10-1ubuntu3.6 => 5.3.10-1ubuntu3)
   php5-mysql (5.3.10-1ubuntu3.6 => 5.3.10-1ubuntu3)
   php5-sqlite (5.3.10-1ubuntu3.6 => 5.3.10-1ubuntu3)
   php5-sybase (5.3.10-1ubuntu3.6 => 5.3.10-1ubuntu3)

So it looks like I would be fine.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

No. PHP is not a dependency of Ubuntu 13.04.

FYI, when you do sudo apt-get dist-upgrade via the command line, it will list all packages that are slated for upgrade. You can double check for PHP's existence.

share|improve this answer
1  
Actually, it wouldn't tell the version unless you use the -v switch. –  Braiam Sep 20 '13 at 16:44
    
And this is what I ended up using to make my final decision. So WINNER!!! –  pthurmond Sep 20 '13 at 18:49
add comment

I found something really interesting while I was searching some more points for your question. This will help you understand more about an Upgrading process. You may read it here. In addition to that, I assume below will help you to understand too;

As I know, Ubuntu by default doesn't have Apache, PHP, MySQL running. You will have to install afterwards. And an OS upgrade will not effect your /home/ files but all system settings /etc/ with the set of default (automatically) installed packages. Since LAMP isn't a default package, I don't think it will make any changes unless if there's any needs. Because the updater looks for a newer version of manually installed packages.

To further investigate, you can use sudo apt-mark showmanual package-name or just sudo apt-mark showmanual to check for the manual and sudo apt-mark showauto to view automatically installed packages.

Sources which helped me to collect info;

Hope these helps!

share|improve this answer
    
Looks like I got some more reading today. Thanks for the info! –  pthurmond Sep 20 '13 at 17:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.