Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.04 and I need to install some tools(I am root). When using apt-get...etc. I kept getting the advice from Ubuntu to first to apt-get install. Wich didn't work, and led me to trying apt-get -f install. Wich didn't work either and starts giving this error:

pkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Examining /etc/kernel/postrm.d . run-parts: executing
/etc/kernel/postrm.d/initramfs-tools 3.2.0-53-generic
/boot/vmlinuz-3.2.0-53-generic run-parts: executing
/etc/kernel/postrm.d/zz-update-grub 3.2.0-53-generic
/boot/vmlinuz-3.2.0-53-generic Errors were encountered while
processing: 
/var/cache/apt/archives/linux-image-3.2.0-53-generic_3.2.0-53.81_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Can anyone help me?

share|improve this question

marked as duplicate by Braiam, jokerdino Sep 24 '13 at 13:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Please also post the line BEFORE the "pkg-deb ..." notice. It is prob. something like "dpkg: error processing /var/cache/apt/archives/ ... trying to overwrite ...". –  Rinzwind Sep 20 '13 at 12:27

Browse other questions tagged or ask your own question.