Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On my Ubuntu 13.04 machine, I used to have the Updated and Optimized Open Graphics Drivers PPA enabled and with a recent update it required Wayland as a dependency. This seems to have broken my package system.

I disabled this PPA so when I try to upgrade, I get the following

sudo apt-get upgrade 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libegl1-mesa : Depends: libwayland-client0 (>= 1.2.1) but it is not installable
                Depends: libwayland-server0 (>= 1.2.1) but it is not installable
                Recommends: libegl1-mesa-drivers but it is not installed
 libgail-3-0 : Depends: libgtk-3-0 (= 3.6.4-0ubuntu8+gd~r) but 3.6.4-0ubuntu8 is installed
 libgbm1 : Depends: libwayland-client0 (>= 1.2.1) but it is not installable
           Depends: libwayland-server0 (>= 1.2.1) but it is not installable
 libgl1-mesa-dev : Depends: libgl1-mesa-glx (= 9.3~git1309181129.ec44d5~gd~r) but 9.3~git1309171217.a1b6e6~gd~r is installed
 libgtk-3-0 : Depends: libgtk-3-common (= 3.6.4-0ubuntu8) but 3.6.4-0ubuntu8+gd~r is installed
 libgtk-3-bin : Depends: libgtk-3-0 (>= 3.6.4-0ubuntu8+gd~r) but 3.6.4-0ubuntu8 is installed
E: Unmet dependencies. Try using -f.

I do not dare doing sudo apt-get -f install since this will remove a huge amount of packages, including unity, network-manager-gnome, etc.

What should I do? I tried installing Synaptic (and one of its dependencies, libgtk-3-0) from DEB packages found on Launchpad, but this failed also.


I am ready to remove said PPA totally, using ppa-purge. When I try that, the solutions it presents always imply removing Unity, which I do not want.


Here is the output of sudo apt-get check:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libegl1-mesa : Depends: libwayland-client0 (>= 1.2.1) but it is not installable
                Depends: libwayland-server0 (>= 1.2.1) but it is not installable
                Recommends: libegl1-mesa-drivers but it is not installed
 libgail-3-0 : Depends: libgtk-3-0 (= 3.6.4-0ubuntu8+gd~r) but 3.6.4-0ubuntu8 is installed
 libgbm1 : Depends: libwayland-client0 (>= 1.2.1) but it is not installable
           Depends: libwayland-server0 (>= 1.2.1) but it is not installable
 libgl1-mesa-dev : Depends: libgl1-mesa-glx (= 9.3~git1309181129.ec44d5~gd~r) but 9.3~git1309171217.a1b6e6~gd~r is installed
 libgtk-3-0 : Depends: libgtk-3-common (= 3.6.4-0ubuntu8) but 3.6.4-0ubuntu8+gd~r is installed
 libgtk-3-bin : Depends: libgtk-3-0 (>= 3.6.4-0ubuntu8+gd~r) but 3.6.4-0ubuntu8 is installed
E: Unmet dependencies. Try using -f.
share|improve this question
    
what version if ubuntu are you using? I strongly suspect the PPA owner is using this PPA in combination with the ricotz PPA which has this version of libwayland (ubuntuupdates.org/ppa/gnome_shell?dist=raring). Do you really need this PPA - or is it easier just to ppa-purge the PPA to get back to stock ubuntu? –  fossfreedom Sep 20 '13 at 9:13
    
Could you add sudo apt-get check output? –  Braiam Sep 24 '13 at 13:37

2 Answers 2

Try these commands:

sudo dpkg -i --force-overwrite /var/cache/apt/archives/libwayland-client0_1.2.1-1~r~gd_amd64.deb /var/cache/apt/archives/libwayland-server0_1.2.1-1~r~gd_amd64.deb
sudo apt-get install -f
sudo apt-get dist-upgrade
sudo dpkg -i --force-overwrite /var/cache/apt/archives/libwayland-cursor0_1.2.1-1~r~gd_amd64.deb
sudo apt-get dist-upgrade
share|improve this answer
    
Could you please explain what this does? –  Agmenor Sep 27 '13 at 8:05
    
Thank you for your answer. install -f would like to make me uninstall Unity again. dist-upgrade brings the error that the following packages have unmet dependencies: libgail-3-0 libgl1-mesa-dev libgtk-3-0 libgtk-3-bin. –  Agmenor Sep 27 '13 at 8:20
up vote 0 down vote accepted

What I did in the end was reinstall Ubuntu, since I wanted to upgrade to Ubuntu 13.10 anyway.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.