Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I do import numpy on my shell, numpy is found (I can use it). However, when I workon my virtualenv import numpy gives me no module named numpy error.

I tried to pip install numpy while working on my virtualenv but I get a could not create '/usr/lib/python2.7/site-packages' error. I tried with sudo and it says that Requirement already satisfied.

Why?

share|improve this question

1 Answer 1

numpy is installed globally in your system, so it's ok that virtualenvcan not find it (unless you specified --system-site-packages option).

The problem with pip install numpy may come from the outdated pip and virtualenv combo. Check versions of your tools and try recreating it with virtualenv 1.11.6 (which includes pip 1.5.6). If the problem persists, report the bug at virtualenv tracker.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.