Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two identical NUCs, boot from USB CD, install the OS, works fine. Install was not adding any drivers or 3rd party apps. Take the same mSATA drive to the other NUC, and it won't boot. I have tried 32 and 64 bit. Checked to make the sure the drive is seen in the BIOS (it is). Have tried uncecking in the BIOS UEFI and Legacy, to no avail.

I have had two other people confirm the same thing on their own systems.

share|improve this question
    
Could you change NUC for the complete term. A google search gave me 5 unrelated results. –  Braiam Sep 20 '13 at 11:17
add comment

1 Answer

EFI relies on NVRAM entries to point it to boot loaders. See this page, and in particular the section entitled "The EFI Boot Process," for details. To fix your problem you must either create new NVRAM entries by using an emergency disc and efibootmgr (or a similar tool in another OS or environment) or install a boot loader as EFI/BOOT/bootx64.efi (assuming an x86-64 CPU and 64-bit EFI).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.