Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, for a first time try with a USB boot drive, i used the recommended Ubuntu 12.04.3 version. After using the pen drive Linux USB installer to install Ubuntu onto it, I restarted my PC and changed the boot priorities in the BIOS so that it boots from the USB first, however after many attempts my PC just boots straight into win 8. The board I have is the ASUS M4A79XTD Evo (AM3). Any help will be much appreciated, thanks

share|improve this question

3 Answers 3

I would first double check whether your boot loader really starts reading from USB device. Then try the USB on other computer (with correct boot priority of course).

It also might be that the USB has not been correctly written.

If the USB is able to boot your other PC, so perhaps 12.04 misses some of your goal PC drviers. In this case using a 13.04 image can resolve the problem.

share|improve this answer
    
Thanks for the help, but after checking the boot priority and testing it out on another PC, the same problem occurs. I'll try 13.04 and post back if that fixes the problem. –  Josh Sep 19 '13 at 20:47

What i would do, is format the USB as FAT32, then use the Linux USB installer again. please reply if it worked. If that doesn't work perhaps try a Live CD?

share|improve this answer
    
Thanks, i'll give that a go if what im now trying (installing again with the format drive option selected), but im not in any immediate hurry so I may as well try all the options :) –  Josh Sep 19 '13 at 20:58
    
if it worked mark the answer as accepted. –  Evgeny Danilenko Sep 20 '13 at 4:09

Had the same problem for booting off a live disc on a toshiba laptop with a preloaded Windows 8 OS. Since you know how to enter your bios to change your boot order I would recommend checking a few other important settings first.

  1. Have you disabled 'Fast Startup' in Windows. (admin rights)

    Enter 'Control Panel'. Click/Search 'Power Options'. On the left side panel click 'Choose what the power buttons do'. Click 'Change settings that are currently unavailable' that is located at the top. Near the bottom of the next page uncheck 'Turn on fast startup (recommended)'

  2. Have you disabled 'Secure Boot' and 'UEFI' mode in your bios.

    Enter your bios and navigate to the 'Security' section - make sure 'Secure Boot' is disabled. Navigate to the 'Advanced' section in your bios and make sure your 'Boot Mode' is 'Legacy' NOT 'UEFI' - if 'Boot Mode' is not visible under 'Advanced' look for it under 'System Configuration'.

  3. To change everything back to their original settings redo steps 2 and 1 in opposite order ; )

*Never prefered to use a usb installer. You are better off booting from a live dvd and partitioning the usb yourself. JUST MAKE SURE YOU SELECT THE APPROPRIATE DRIVE!!! I always used 'http://www.linuxbsdos.com/2011/05/23/install-ubuntu-11-04-on-external-hard-disk/' when installing on an external device

share|improve this answer
    
Thank you so much! After trying other suggestions, and asking one of my friends who runs a dual boot, nothing seemed to work. At first I thought that my motherboard just didn't have the drivers for USB booting, so tried from a disk which still didn't work, which really puzzled me. So, I disabled fast start up (which I thought would not affect the boot too much) and it finally worked! Also, thanks for the link about installing on an external storage device, as now I have a boot disk and have formatted my pen drive, I may as well save the time :) –  Josh Sep 20 '13 at 16:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.