Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have HP pavilion m6-1002tx dual boot (Windows 7 Home Premium & Ubuntu 13.04),64-bit. I find no sign of a working subwoofer, at back side of my laptop. Also in all setting->sounds, the option of woofer is inactive. As I'm new to ubuntu, I expect something to set it working, with help of extra sound drivers to be installed, if needed so!

Please help!

share|improve this question

2 Answers 2

Check alsamixer (alsamixer in terminal), to see that the subwoofer is not muted which sometimes may be happen.

Otherwise editing /etc/modprobe.d/alsa-base.conf usually works

In terminal run gksu gedit /etc/modprobe.d/alsa-base.conf

Add the following at the end then save:

options snd-hda-intel model=auto

or

options snd-hda-intel model=ref

Then reboot. Check alsamixer and sound settings again after each attempt.

/usr/share/doc/alsa-base/driver/HD-Audio-Models.txt.gz has a list of models to put instead of auto/ref, I don't see your model in there, but maybe one of the others using the same codec will work.

Run cat /proc/asound/card0/codec* | grep Codec to discover your codec (mine is 92hd91), so not supported there either, but sometimes one of the others does the job.

share|improve this answer
sudo add-ppa-repository ppa:diwic/hda
sudo apt-get update
sudo apt-get install hda-jack-retask
hda-jack-retask
  1. Chose your sound card
  2. Check "Show unconnected pins"
  3. Try to override pins one by one switching to "Internal speaker(LFE)". It was id:0x10 in my case.

Don't forget aplly after every change and check result. After you found the right pin press "Install boot ovverride"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.