Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I noticed today that there is a directory located in /media/myusername called "SSH2013-09-16". I tried to remove it, but rmdir reports "Device or resource busy". This even happens if I try to remove it with sudo. Does anyone know what this directory is for, if it should be there, and if not, how I can remove it?

Thanks!

Note: I am running Ubuntu 12.10 64bit Desktop

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Solved It! Although my cd drive was empty, /dev/sr0 was still mounted to that location. By going to the file manager and clicking the eject button, it unmounted it. It seems to me like an Ubuntu bug since there was nothing in my cd tray (and there hasn't been for two days now). Using the "mount" (as root without arguments) command was helpful to me since it listed all the current mounts.

share|improve this answer
    
You can enter mount in terminal or open the system monitors filesystem tab to get an overview of mounted filesystem/devices. Kudos for confusing people by including "SSH" in the name of the mountpoint and non-deliberately confusing people. :) –  LiveWireBT Sep 19 '13 at 16:31

Always that a device is automagically mounted, the system uses this kind of path to do this. When a device is removed without properly unmounted, this can be happen.

share|improve this answer

I would say you mounted an ssh folder ans it's still used. you should try unmounting it first

share|improve this answer
    
Thanks for the answer. It got me thinking that it might be an old mount, so I tried the mount command. Apparently Ubuntu hadn't recognized that the cd had been removed a few days ago. See my answer for more details. It wasn't an ssh mount, but it got me looking in the right place. –  Daniel Sep 19 '13 at 14:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.