Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I successfully installed 12.04 on my Lenovo U410 64-bit Windows 8 machine after several failed attempts, and I would like to share my solution to this problem with you:

First, get the live disc for the version of Ubuntu that you want. I installed 12.04 LTS. Windows 8 (in my experience) is usually run on 64-bit machines, so you'll likely need the 64-bit version of 12.04.

Next, put the live disc in your optical drive. Despite what you may expect, you will not be able to successfully boot off of the Live disc because of the firmware called Secure Boot. This is in place to prevent someone from accessing the admin account for Windows 8 and stealing your information. The next step is to get around this firmware.

Next, go into the general settings found under the 'change PC settings' menu. Scroll to the bottom and click the 'Advanced Start-Up' section and click the button that says 'Restart Now'. You will see a waiting screen, and then several options to click on. Click on 'Troubleshooting'. Then click on 'Advanced Options'. Then click 'UEFI Firmware Settings'. Then click on the restart button shown on your screen. This restarts your computer and gives you access to your BIOS.

Use your tab key to get to a tab that says something like 'App Menu'. Then arrow to the option that says Setup and hit enter. You'll then see a blue screen that has several tabs at the top. Go to the 'Security' tab and there will be an option for 'Secure Boot' that should be greyed out. If it's not, then arrow down to it and hit enter, then select 'Disabled'. Otherwise, go through the tabs and look for an option that has the abbreviation 'UEFI' next to it. Change this option to 'Legacy Support'. You should then see an option in the same menu that says 'Boot Priority'. Change this from 'UEFI first' to 'Legacy first'. Then hit the function key that saves and exits the BIOS.

You should now be able to boot from the live disc and install Ubuntu. Enjoy!

share|improve this question
add comment

3 Answers

According to this page: http://noelkurian.tk/2013/03/dual-booting-windows-7-and-archlinux-on-lenovo-ideapad-u410/, this can be used as for Ubuntu as for other distros to install. Did you follow a similar aproach to install Ubuntu or you just did it in a different way?

share|improve this answer
add comment

I actually tried something similar to this, but couldn't get it to work. The main problem that I ran into was that I couldn't get Secure Boot to allow me access to this partition. For some reason, I found that this problem only arises when using windows 8 machines with the UEFI firmware options. I originally booted off a live disc by accessing the BIOS and changing the boot priority so that the live disc would boot first. I then installed 12.04, but when I restarted my machine, Secure Boot prevented 12.04 from starting up. To be honest, I only figured this problem out by trial and error. Since I didn't install Archlinux, I'm not sure if this procedure would actually work, but I suppose it could.

One problem I've had so far is that I can no longer access Windows 8. I tryed selecting that OS from the boot menu, but whenever I do, I get an error message that says 'No valid BIOS detected' or something like this. Any ideas?

Michael

share|improve this answer
add comment

I have a HP dv6 series lappy with 3rd gen i7.

What i did was: I booted from USB. Then installed in specific drive. Then to my surprise, i didn't get the GRUB loader. Then finally figured that it was listed in Boot manager.

Something you get when you hit Esc or fn + f10. There was an entry titled ubuntu

Note: My system is UEFI enabled and using windows 8 in UEFI. Hope, this suggesstion is valuable

share|improve this answer
    
I tried this too, but couldn't get the boot manager to show up. I tried many different hotkeys directly after booting up my machine and got the same result. I tried esc, fn + f10, f2, f8, f9, ctrl + f10, etc none of which displayed the boot manager. Many of the other posts about this subject listed similar instructions, but None of them worked. But you were able to boot Ubuntu while UEFI was enabled? That's really interesting. Perhaps it's a manufacture variation that allows you to do that. Lenovo seems to be the only brand this particular problem. –  Micahel Oct 14 '13 at 18:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.